Плагин слишком стар, обновите его до более поздней версии или установите переменную окружения ANDROID_DAILY_OVERRIDE в

Сегодня я просто импортировал пример приложения из Android SDK в качестве модуля в свой проект (аналитика), и вдруг я получил эту ошибку градиента, когда я пытаюсь ее синхронизировать: Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE envrinment variable to...

Это файл моего приложения:

 apply plugin: 'com.android.application' android { compileSdkVersion 22 buildToolsVersion "22.0.0" defaultConfig { applicationId "xxx.xxxxxx.xxxxx" versionCode 1 versionName '1' minSdkVersion 9 targetSdkVersion 22 versionCode 1 versionName '1' } buildTypes { release { minifyEnabled false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:appcompat-v7:22.0.0' compile 'com.google.android.gms:play-services:6.5.87' compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cardview-v7:21.0.0' compile 'com.facebook.android:facebook-android-sdk:3.21.1' testCompile 'junit:junit:4.12' compile project(':volley') } 

Есть ли у вас какие-либо представления о том, что может быть причиной (я использую версию плагина 1.1.0-rc1, а также версию 2.2 и версию для Android Studio версии 1.1.0)?

РЕДАКТИРОВАТЬ:

Это мой топ build.gradle :

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:1.1.0-rc1' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { jcenter() } } 

Solutions Collecting From Web of "Плагин слишком стар, обновите его до более поздней версии или установите переменную окружения ANDROID_DAILY_OVERRIDE в"

Также, как и CommonsWare, убедитесь, что у вас есть Gradle 2.2.1+ (последнее – 2.3).

Убедитесь, что вы обновили свою версию Android Studio, но здесь есть «плагины», которые необходимо обновить:

Top build.gradle :

Изменить:

 classpath 'com.android.tools.build:gradle:1.1.0-rc1' 

Для того, чтобы:

 classpath 'com.android.tools.build:gradle:1.1.3' // latest 1.5.0 

App build.gradle :

Изменить:

 compile 'com.android.support:recyclerview-v7:21.0.0' compile 'com.android.support:cardview-v7:21.0.0' 

Для того, чтобы:

 compile 'com.android.support:recyclerview-v7:22.0.0' // latest 23.1.1 compile 'com.android.support:cardview-v7:22.0.0' // latest 23.1.1 

Gradle: https://gradle.org/downloads

Всегда проверяйте Android SDK Manager на наличие последних версий:

Плагин для Android Build Tools: http://tools.android.com/tech-docs/new-build-system

Библиотеки поддержки Android: http://developer.android.com/tools/support-library/features.html

Чтобы просмотреть последние версии плагинов, просмотрите страницу Bintray Jcenter напрямую: https://bintray.com/android/android-tools/com.android.tools.build.gradle/view .

Решение (Обновлено: 24-май-2016): Изменить build.gradle (проект)

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:XXX-lastVersionGradle' classpath 'com.google.gms:google-services:XXX-lastVersionGServices' // If use google-services // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } 

XXX-lastVersionGradle : Например: 2.1.0

XXX-lastVersionGУслуги : Например: 3.0.0 (поддержка Firebase Analytics)

Примечание. Если вы используете плагин google-services, должна быть одна и та же версия (если есть)

Предупреждение!! -> 2.2.0-alpha бросает Unsupported major.minor версии 52.0, если вы не используете java JDK 8u91 и NetBeans 8.1

В качестве побочного примечания, я получал ту же ошибку в совершенно несвязанной ситуации – после того, как была изменена установка моего системного года (т.е. 2015 -> 2016); Изменение часов назад на правильное решение проблемы.

Примечание 1: Я публикую это в основном потому, что у меня было точно такое же сообщение об ошибке, но работающее решение оказалось отличным от обновления версии плагина (как опубликовал Jared Burrows ).

Примечание 2: использование

 classpath 'com.android.tools.build:gradle:+' 

Может сделать версию плагина по умолчанию самой новой. Имейте в виду, что ваша сборка может нарушить API-изменения (и по этой причине не рекомендуется документам API Android), поэтому используйте это на свой страх и риск, только если вы постоянно обновляете версию в любом случае.

На всякий случай кто-то борется с этим, в моем случае я использую Gradle 1.4 beta 1, и мне НЕОБХОДИМО сохранить его. Поэтому, чтобы заставить Android Studio работать с терминалом и запускать это:

launchctl setenv ANDROID_DAILY_OVERRIDE <your-value-on-error-message>

Перезагрузите Android Studio, и проект будет построен снова.

Kudos to UPDATE 2 здесь: https://emmanuelbernard.com/blog/2012/05/09/setting-global-variables-intellij/

Вы всегда можете проверить последнюю версию плагина gradle: https://bintray.com/android/android-tools/com.android.tools.build.gradle

Итак, на сегодняшний день вы должны использовать:

classpath 'com.android.tools.build:gradle:2.2.2'

соответственно.

Замените свой путь класса чем-то неоднозначным. Это решение, и оно работает, но это не может быть хорошим решением.

Classpath 'com.android.tools.build:gradle:+'

Лучший способ – заменить + на последнюю версию gradle

Проверьте последнюю версию Gradle Plugin:

Скачать

Вы должны изменить это в зависимости от настроек приложения

 buildscript { repositories { jcenter() } dependencies { classpath 'com.android.tools.build:gradle:[PLACE VERSION CODE HERE]' } 

}

Эта проблема возникает из-за изменений версии Gradle, поскольку ваше приложение использует старую версию gradle, вам нужно обновить ее до новой версии.

Эти изменения необходимо сделать в файле build.gradle, посмотрите на эту ссылку http://www.feelzdroid.com/2015/11/android-plugin-too-old-update-recent-version.html . Знать, как обновить градиент и подробные шаги. там.

Thans

Я использую привязку данных Android, и сегодня у меня такая же проблема.

Чтобы решить эту проблему, измените:

 classpath "com.android.databinding:dataBinder:1.0-rc0" 

Для того, чтобы:

 classpath "com.android.databinding:dataBinder:1.0-rc1" 

1.0-rc0 все еще можно найти в jcenter сейчас, я не знаю, почему это невозможно использовать.

Я получил способ, который, наконец, разрешил это: 1. Проверьте свой calsspath в top build.gradle, например my – classpath 'com.android.tools.build:gradle:2.1.0-alpha3', затем перейдите в https: // jcenter. Bintray.com/com/android/tools/build/gradle/ найти выпуск, который является более новым, чем ваш, здесь я выбираю 2.1.0-beta3 change classpath ниже, а затем запускаю сборку. Classpath 'com.android.tools.build:gradle:2.1.0-beta3'

Если вы хотите продолжать использовать новейшие версии версий, эта проблема может повторяться каждый раз, когда ваша версия достаточно устарела.

Я сохраняю обновленный список самых современных версий разработки, а также стабильную версию моего ответа на этот похожий вопрос, так что я могу исправить его каждый раз, когда получаю новое предупреждение:

Android Studio 2.0 – Плагин слишком стар, обновите его до более новой версии или установите ANDROID_DAILY_OVERRIDE

Установите переменную среды ANDROID_DAILY_OVERRIDE на то же значение Пример – b9471da4f76e0d1a88d41a072922b1e0c257745c

Это работает для меня.

Вы должны обновить версию градиента. Например: com.android.build.gradle 1.3.0

Эта проблема возникает, когда изменяется версия градиента.

Решение об удалении части «-rcX» работает. Я хотел бы предоставить более подробную информацию о том, почему происходит ошибка. Проблема связана с https://android.googlesource.com/platform/tools/base/+/master/build-system/gradle/src/main/groovy/com/android/build/gradle/BasePlugin.java#230

Существует 40-дневный возраст выхода на пенсию для плагинов, которые не имеют версии или содержат «rc», «alpha» или «beta».

В последние месяцы я использовал «предварительную» версию Android Studio. Я попытался вернуться к «стабильным» релизам для обновлений программного обеспечения, но этого было недостаточно, и я получил эту известную ошибку, о которой вы говорите.

Удаление моего Android Studio 2.2.preview и установка последней стабильной Android Studio (2.1) исправили ее для меня 🙂

Пойдите для стабильной версии или градации в файле градиента уровня приложения в моем случае это было
Classpath 'com.android.tools.build:gradle:2.2.0-alpha3'

Я изменил его с помощью

Classpath 'com.android.tools.build:gradle:2.1.2'