Intereting Posts
Использование диалога общего доступа в Android Facebook SDK. Как узнать, действительно ли пользователь разделяет или отменяет совместную деятельность? Как установить эффект пульсации на textview или изображение на Android? ActivityCompat.requestPermissions не показывает диалоговое окно Как я могу проверить из Android WebView, если страница «404 страница не найдена»? Какую платформу ведения журнала Android использовать? Получение заполнения по умолчанию для AlertDialog Загрузка и сохранение изображений с помощью Picasso Лучшие методы для запроса базы данных SQLite в ListFragment с помощью CursorLoader? Студия Android: отладка приложения на устройстве Заставить Android-телефон спать, чтобы проверить? Android Picasso – стиль размещения и ошибки изображения Как записать звук с помощью Bluetooth-гарнитуры Просмотр анимации справа налево Элегантный способ чтения файла в массив byte в Java Chrome on android изменяет размер шрифта

Не удалось применить плагин. Плагин Android Gradle 3.0.0-alpha5 не должен применяться к проекту.

Использование последней версии Android Studio 3.0 Canary 5

Вот ошибка:

Ошибка: (1, 1) Возникла проблема с оценкой проекта ': app'.

Не удалось применить плагин [class 'com.android.build.gradle.api.AndroidBasePlugin'] Android Gradle plugin 3.0.0-alpha5 не должен применяться к проекту [path_to_my_project], поскольку версия 3.0.0-alpha5 уже была применена к этому проекту

Пробовал: чистка, перестройка, открытие / закрытие. Не работает.

есть идеи ?

[LATER EDIT] Решение: Перейдите на Canary 8+, и все должно быть в порядке.

Solutions Collecting From Web of "Не удалось применить плагин. Плагин Android Gradle 3.0.0-alpha5 не должен применяться к проекту."

Из этого потока на reddit: https://www.reddit.com/r/androiddev/comments/6kjl8b/android_studio_30_canary_5_is_now_available/djmuv0o/ убивающие демоны исправили проблему для меня.

./gradlew --stop 

Это сработало для меня:

Деактивировать конфигурацию по требованию

В gradle.properties :

 org.gradle.configureondemand=false 

Затем остановите демон в окне терминала:

 gradlew.bat --stop 

Теперь все работает снова.

Используемые версии:

  • Android Studio 3.0 Canary 5
  • Gradle: gradle-4.1-milestone-1
  • Плагин android gradle: com.android.tools.build:gradle:3.0.0-alpha5

Миграция версии gradle от 3.0.0-alpha5 до 3.0.0-alpha7 спасла мой день!

Я получил проблему и понял проблему, связанную с кешами. Вы должны сделать недействительными кеши студии Android, выбрав « Файл-> Недействительный кеш / перезапуск». Это сработало для меня. Проблема была решена.

Откройте терминал и напишите

 ./gradlew --stop 

В gradle.properties убедитесь, что у вас нет смешного материала

Обратите внимание, что нет настраиваемых jvmargs …

 org.gradle.daemon=true org.gradle.parallel=true org.gradle.configureondemand=false 

Включите репозиторий google () в build.gradle (проект один)

Вот как выглядит мой

build.gradle

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { jcenter() google() maven { url "http://objectbox.net/beta-repo/" } } dependencies { classpath 'io.objectbox:objectbox-gradle-plugin:0.9.12.1' classpath 'com.android.tools.build:gradle:3.0.0-alpha5' // NOTE: Do not place your application dependencies here; they belong // in the individual module build.gradle files } } allprojects { repositories { maven { url 'https://jitpack.io' } jcenter() google() maven { url "http://objectbox.net/beta-repo/" } } } task clean(type: Delete) { delete rootProject.buildDir } 

Наконец, версии библиотеки поддержки в файле build.gradle приложения

build.gradle

 ... //----- Support Libs implementation 'com.android.support:appcompat-v7:26.0.0-beta2' implementation "com.android.support:design:26.0.0-beta2" implementation "com.android.support:recyclerview-v7:26.0.0-beta2" implementation "com.android.support:cardview-v7:26.0.0-beta2" ... 

Я уже пробовал все решения, включая Clean, Rebuild, Invalidate Project

Но ничего не работает, но я понял это.

Для временного просто понизите версию вашего плагина gradle до стабильной версии

 classpath 'com.android.tools.build:gradle:2.3.2' 

Замените вашу альфа-линию этой строкой. И веселиться.. 🙂