Unparsed aapt error (s)!

Я работаю с Android в Eclipse и пытаюсь объединить код из проекта шаблона, который я нашел в проекте скелета, который создает Android при запуске нового проекта. Это не первоначальная настройка; Получили несколько проектов, и хотя я новичок в кодировании Android, я работал в течение нескольких недель без этой проблемы, поэтому среда настроена отлично, я думаю.

Ошибка, которую я вижу, – это –

Unparsed aapt error(s)! Check the console for output 

В какой-то момент я очистил консольные сообщения и теперь даже после закрытия проекта и Eclipse, а затем снова открыв, я не получаю консольных сообщений, и ни один из моих исходных файлов или файлов ресурсов не помечен.

Что такое aapt и где я должен искать источник этой ошибки? Заранее спасибо за вашу помощь.

Solutions Collecting From Web of "Unparsed aapt error (s)!"

Я разобрал это. Так что для кого-то еще, кто все еще учится у меня на пути обучения, солюшенность отмечена в моем комментарии. К тому же –

Aapt = Инструмент для упаковки активов от Android. В «Руководстве для разработчиков » «Инструмент пакетной обработки Android (aapt) принимает файлы ресурсов приложения, такие как файл AndroidManifest.xml и файлы XML для ваших действий, и компилирует их».

Решение для меня было просто удалить ошибку в окне «Проблема» (щелкните правой кнопкой мыши | удалить). Затем принудительно перезагрузите приложение. Все оставшиеся проблемы теперь будут отображаться и регистрироваться, чтобы вы могли отслеживать их.

Надеюсь, это полезно для других.

Это произошло для меня, когда я случайно попытался «запустить» файл макета Android XML. Он создал файл с именем макета и добавленным _out.xml . Мне нужно было удалить этот файл, прежде чем я смогу выполнить дальнейшие сборки.

Это то, что я использовал с использованием Eclipse ADT, и эта ошибка исчезла:

Окно> Настройки> Android> DDMS> Базовый локальный порт отладчика: 8600

Я изменил значение с 8600 на что-то еще, например: 9999

Наконец, я пошел в Project> Clean …> Очистить все проекты> OK

Ошибка исчезла.

Может возникнуть, когда проект будет создан (новый Android) и поля: минимальный требуемый SDK, целевой SDK, компиляция и тема не заполнены правильно.