Не удалось обновить проект Studio Studio 0.5.2

ОБНОВЛЕНО С МОИМ СОБЫТИЕМ

ПОСЛЕДНИЙ РЕДАКТИРОВАТЬ После того, как вы опробовали все возможные решения, я мог найти, что я пришел к новой установке Windows. Сделав это, я заметил, что это было связано с проблемой брандмауэра , мой антивирус блокировал studio64.exe process.

Я недавно установил Android Studio 0.4.2, а затем сразу обновился до 0.5.2 без открытия или создания каких-либо новых проектов.

Я обновил Android SDK, а затем создал новый проект. Я продолжаю получать ошибку с ошибкой Gradle Refresh, хотя я пытался изменить локальный дистрибутив градиента, ничего не работает, все, что я пытаюсь ответить Gradle: «Пожалуйста, исправьте конфигурацию Gradle» …

Это случилось со мной, так как я обновился до Android studio 5.1, никогда раньше.

Я пробовал с Gradle 1.10 и 1.11, а оболочку Gradle, включенную в установочный комплект, можно загрузить с веб-сайта http://developer.android.com/sdk/installing/studio.html

Вот мои файлы градиентов:

 apply plugin: 'android' android { compileSdkVersion 19 buildToolsVersion "19.0.3" defaultConfig { minSdkVersion 8 targetSdkVersion 19 versionCode 1 versionName "1.0" } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } } dependencies { compile 'com.android.support:appcompat-v7:+' compile fileTree(dir: 'libs', include: ['*.jar']) } 

И внешний файл build.gradle.

 // Top-level build file where you can add configuration options common to all sub-projects/modules. buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.9.+' } } allprojects { repositories { mavenCentral() } } 

Теперь я попытался загрузить последнюю версию из Canary Build, а затем загрузить SDK отдельно, по-прежнему та же проблема, это действительно раздражает … есть ли какие-либо настройки сети, которые могут быть неправильно настроены?

В настоящее время я использую по умолчанию grale wrapper от Android Studio, и это ошибка, которую я получаю:

 10:58:37 AM Gradle 'ClujTourist' project refresh failed: A fatal exception has occurred. Program will exit. : Gradle settings 

После попытки скомпилировать проект с помощью: gradlew.bat --stacktrace assemble

Это то, что я получил:

 C:\Users\Adrian-PC\AndroidStudioProjects\ClujTourist>gradlew.bat --stacktrace as semble FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring root project 'ClujTourist'. > Could not resolve all dependencies for configuration ':classpath'. > Could not find any version that matches com.android.tools.build:gradle:0.11 .+. Required by: :ClujTourist:unspecified * Try: Run with --info or --debug option to get more log output. * Exception is: org.gradle.api.ProjectConfigurationException: A problem occurred configuring roo t project 'ClujTourist'. at org.gradle.configuration.project.LifecycleProjectEvaluator.addConfigu rationFailure(LifecycleProjectEvaluator.java:79) at org.gradle.configuration.project.LifecycleProjectEvaluator.evaluate(L ifecycleProjectEvaluator.java:57) at org.gradle.api.internal.project.AbstractProject.evaluate(AbstractProj ect.java:507) at org.gradle.api.internal.project.AbstractProject.evaluate(AbstractProj ect.java:82) at org.gradle.configuration.DefaultBuildConfigurer.configure(DefaultBuil dConfigurer.java:31) at org.gradle.initialization.DefaultGradleLauncher.doBuildStages(Default GradleLauncher.java:142) at org.gradle.initialization.DefaultGradleLauncher.doBuild(DefaultGradle Launcher.java:113) at org.gradle.initialization.DefaultGradleLauncher.run(DefaultGradleLaun cher.java:81) at org.gradle.launcher.exec.InProcessBuildActionExecuter$DefaultBuildCon troller.run(InProcessBuildActionExecuter.java:64) at org.gradle.launcher.cli.ExecuteBuildAction.run(ExecuteBuildAction.jav a:33) at org.gradle.launcher.cli.ExecuteBuildAction.run(ExecuteBuildAction.jav a:24) at org.gradle.launcher.exec.InProcessBuildActionExecuter.execute(InProce ssBuildActionExecuter.java:35) at org.gradle.launcher.exec.InProcessBuildActionExecuter.execute(InProce ssBuildActionExecuter.java:26) at org.gradle.launcher.cli.RunBuildAction.run(RunBuildAction.java:50) at org.gradle.internal.Actions$RunnableActionAdapter.execute(Actions.jav a:171) at org.gradle.launcher.cli.CommandLineActionFactory$ParseAndBuildAction. execute(CommandLineActionFactory.java:201) at org.gradle.launcher.cli.CommandLineActionFactory$ParseAndBuildAction. execute(CommandLineActionFactory.java:174) at org.gradle.launcher.cli.CommandLineActionFactory$WithLogging.execute( CommandLineActionFactory.java:170) at org.gradle.launcher.cli.CommandLineActionFactory$WithLogging.execute( CommandLineActionFactory.java:139) at org.gradle.launcher.cli.ExceptionReportingAction.execute(ExceptionRep ortingAction.java:33) at org.gradle.launcher.cli.ExceptionReportingAction.execute(ExceptionRep ortingAction.java:22) at org.gradle.launcher.Main.doAction(Main.java:46) at org.gradle.launcher.bootstrap.EntryPoint.run(EntryPoint.java:45) at org.gradle.launcher.Main.main(Main.java:37) at org.gradle.launcher.bootstrap.ProcessBootstrap.runNoExit(ProcessBoots trap.java:50) at org.gradle.launcher.bootstrap.ProcessBootstrap.run(ProcessBootstrap.j ava:32) at org.gradle.launcher.GradleMain.main(GradleMain.java:23) at org.gradle.wrapper.BootstrapMainStarter.start(BootstrapMainStarter.ja va:33) at org.gradle.wrapper.WrapperExecutor.execute(WrapperExecutor.java:130) at org.gradle.wrapper.GradleWrapperMain.main(GradleWrapperMain.java:48) Caused by: org.gradle.api.artifacts.ResolveException: Could not resolve all depe ndencies for configuration ':classpath'. at org.gradle.api.internal.artifacts.ivyservice.DefaultLenientConfigurat ion.rethrowFailure(DefaultLenientConfiguration.java:52) at org.gradle.api.internal.artifacts.ivyservice.DefaultResolvedConfigura tion.rethrowFailure(DefaultResolvedConfiguration.java:36) at org.gradle.api.internal.artifacts.ivyservice.SelfResolvingDependencyR esolver$FilesAggregatingResolvedConfiguration.rethrowFailure(SelfResolvingDepend encyResolver.java:106) at org.gradle.api.internal.artifacts.ivyservice.ErrorHandlingArtifactDep endencyResolver$ErrorHandlingResolvedConfiguration.rethrowFailure(ErrorHandlingA rtifactDependencyResolver.java:176) at org.gradle.api.internal.artifacts.configurations.DefaultConfiguration $ConfigurationFileCollection.getFiles(DefaultConfiguration.java:465) at org.gradle.api.internal.artifacts.configurations.DefaultConfiguration .getFiles(DefaultConfiguration.java:202) at org.gradle.api.internal.artifacts.configurations.DefaultConfiguration _Decorated.getFiles(Unknown Source) at org.gradle.api.internal.initialization.DefaultScriptHandler.updateCla ssPath(DefaultScriptHandler.java:75) at org.gradle.configuration.DefaultScriptPluginFactory$ScriptPluginImpl. apply(DefaultScriptPluginFactory.java:145) at org.gradle.configuration.project.BuildScriptProcessor.execute(BuildSc riptProcessor.java:38) at org.gradle.configuration.project.BuildScriptProcessor.execute(BuildSc riptProcessor.java:25) at org.gradle.configuration.project.ConfigureActionsProjectEvaluator.eva luate(ConfigureActionsProjectEvaluator.java:34) at org.gradle.configuration.project.LifecycleProjectEvaluator.evaluate(L ifecycleProjectEvaluator.java:55) ... 28 more Caused by: org.gradle.api.internal.artifacts.ivyservice.ModuleVersionNotFoundExc eption: Could not find any version that matches com.android.tools.build:gradle:0 .11.+. Required by: :ClujTourist:unspecified at org.gradle.api.internal.artifacts.ivyservice.ivyresolve.LazyDependenc yToModuleResolver$DynamicVersionResolveResult.notFound(LazyDependencyToModuleRes olver.java:170) at org.gradle.api.internal.artifacts.ivyservice.ivyresolve.LazyDependenc yToModuleResolver$AbstractVersionResolveResult.resolve(LazyDependencyToModuleRes olver.java:91) at org.gradle.api.internal.artifacts.ivyservice.ivyresolve.LazyDependenc yToModuleResolver.resolve(LazyDependencyToModuleResolver.java:47) at org.gradle.api.internal.artifacts.ivyservice.VersionForcingDependency ToModuleResolver.resolve(VersionForcingDependencyToModuleResolver.java:48) at org.gradle.api.internal.artifacts.ivyservice.resolveengine.Dependency GraphBuilder$ModuleVersionSelectorResolveState.resolveModuleRevisionId(Dependenc yGraphBuilder.java:935) at org.gradle.api.internal.artifacts.ivyservice.resolveengine.Dependency GraphBuilder$DependencyEdge.resolveModuleRevisionId(DependencyGraphBuilder.java: 296) at org.gradle.api.internal.artifacts.ivyservice.resolveengine.Dependency GraphBuilder.traverseGraph(DependencyGraphBuilder.java:93) at org.gradle.api.internal.artifacts.ivyservice.resolveengine.Dependency GraphBuilder.resolve(DependencyGraphBuilder.java:66) at org.gradle.api.internal.artifacts.ivyservice.resolveengine.DefaultDep endencyResolver$1.transform(DefaultDependencyResolver.java:108) at org.gradle.api.internal.artifacts.ivyservice.resolveengine.DefaultDep endencyResolver$1.transform(DefaultDependencyResolver.java:77) at org.gradle.api.internal.artifacts.ivyservice.DefaultIvyContextManager .withIvy(DefaultIvyContextManager.java:61) at org.gradle.api.internal.artifacts.ivyservice.resolveengine.DefaultDep endencyResolver.resolve(DefaultDependencyResolver.java:77) at org.gradle.api.internal.artifacts.ivyservice.CacheLockingArtifactDepe ndencyResolver$1.create(CacheLockingArtifactDependencyResolver.java:39) at org.gradle.api.internal.artifacts.ivyservice.CacheLockingArtifactDepe ndencyResolver$1.create(CacheLockingArtifactDependencyResolver.java:37) at org.gradle.cache.internal.DefaultCacheAccess.useCache(DefaultCacheAcc ess.java:148) at org.gradle.cache.internal.DefaultPersistentDirectoryStore.useCache(De faultPersistentDirectoryStore.java:123) at org.gradle.api.internal.artifacts.ivyservice.DefaultCacheLockingManag er.useCache(DefaultCacheLockingManager.java:77) at org.gradle.api.internal.artifacts.ivyservice.CacheLockingArtifactDepe ndencyResolver.resolve(CacheLockingArtifactDependencyResolver.java:37) at org.gradle.api.internal.artifacts.ivyservice.SelfResolvingDependencyR esolver.resolve(SelfResolvingDependencyResolver.java:41) at org.gradle.api.internal.artifacts.ivyservice.ShortcircuitEmptyConfigs ArtifactDependencyResolver.resolve(ShortcircuitEmptyConfigsArtifactDependencyRes olver.java:46) at org.gradle.api.internal.artifacts.ivyservice.ErrorHandlingArtifactDep endencyResolver.resolve(ErrorHandlingArtifactDependencyResolver.java:44) at org.gradle.api.internal.artifacts.ivyservice.DefaultConfigurationReso lver.resolve(DefaultConfigurationResolver.java:42) at org.gradle.api.internal.artifacts.configurations.DefaultConfiguration .resolveNow(DefaultConfiguration.java:240) at org.gradle.api.internal.artifacts.configurations.DefaultConfiguration .getResolvedConfiguration(DefaultConfiguration.java:230) at org.gradle.api.internal.artifacts.configurations.DefaultConfiguration _Decorated.getResolvedConfiguration(Unknown Source) at org.gradle.api.internal.artifacts.configurations.DefaultConfiguration $ConfigurationFileCollection.getFiles(DefaultConfiguration.java:463) ... 36 more BUILD FAILED Total time: 7.864 secs C:\Users\Adrian-PC\AndroidStudioProjects\ClujTourist> 

Также попытался удалить файлы .gradle и gradle из моего проекта. Ничто не работает.

EDIT. Кажется, что я работаю для меня до сих пор, заменяя каталог службы .gradle на ваш корневой каталог, поскольку, возможно, в этом каталоге была проблема с путём. Дайте мне знать, если это решит это для вас!

Solutions Collecting From Web of "Не удалось обновить проект Studio Studio 0.5.2"

Легко исправить!

Часть defaultConfig вашего файла build.gradle должна buildTypes внутри buildTypes , например:

 apply plugin: 'android' android { compileSdkVersion 19 buildToolsVersion "19.0.3" buildTypes { defaultConfig { minSdkVersion 8 targetSdkVersion 19 versionCode 1 versionName "1.0" } release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.txt' } } } dependencies { compile 'com.android.support:appcompat-v7:+' compile fileTree(dir: 'libs', include: ['*.jar']) } 

См. Руководство по миграции от 0,8 до 0,9 .

Кроме того, убедитесь, что вы используете обновленный URL-адрес распространения Gradle (если вы используете обложку Gradle).

В вашем файле gradle-wrapper.properties должна быть следующая строка:

 distributionUrl=http\://services.gradle.org/distributions/gradle-1.11-all.zip 

Наконец, убедитесь, что вы clean проект до его сборки (Build -> Clean Project).

В моем случае я пробовал эти два решения выше, но ни один из них не смог решить проблему, наконец, я закрыл свое программное обеспечение безопасности AVAST … тогда это сработало! Ускоренная синхронизация окончена. Хотя я не знаю почему, но закрываю Вниз AVAST решила проблему.

У меня была такая же проблема.

Чтобы решить это, просто создайте еще один проект в Android Studio 0.5.2, а после этого, когда новый проект полностью создан и закроется, закройте его и откройте свой старый проект (проект « ClujTourist »). Теперь вы можете успешно построить ClueTourist.

Пожалуйста, дайте мне знать, если что-то пойдет не так.