Ошибка SERVICE_VERSION_UPDATE_REQUIRED с использованием Firebase Analytics на Android

Я хочу интегрировать Firebase Analytics в свой проект.

Я следовал за Гидом, но это дает мне это предупреждение:

06-30 18:38:30.514 W/FA ( 2091): Service connection failed: ConnectionResult{statusCode=SERVICE_VERSION_UPDATE_REQUIRED, resolution=null, message=null} 06-30 18:38:30.888 W/FA ( 2091): Service connection failed: ConnectionResult{statusCode=SERVICE_VERSION_UPDATE_REQUIRED, resolution=null, message=null} 06-30 18:38:32.306 W/FA ( 2091): Service connection failed: ConnectionResult{statusCode=SERVICE_VERSION_UPDATE_REQUIRED, resolution=null, message=null} 06-30 18:38:32.338 W/FA ( 2091): Service connection failed: ConnectionResult{statusCode=SERVICE_VERSION_UPDATE_REQUIRED, resolution=null, message=null} 06-30 18:38:32.661 W/FA ( 2091): Service connection failed: ConnectionResult{statusCode=SERVICE_VERSION_UPDATE_REQUIRED, resolution=null, message=null} 06-30 18:39:32.680 W/FA ( 2091): Tasks have been queued for a long time 

Моя версия проекта:

 ext { minSdkVersion = 17 targetSdkVersion = 23 compileSdkVersion = 23 compileSdkVersionS = 'Google Inc.:Google APIs:23' supportVersion = '24.0.0' buildToolsVersion = '23.0.2' sourceCompatibilityVersion = JavaVersion.VERSION_1_7 targetCompatibilityVersion = JavaVersion.VERSION_1_7 gradleVersion = '2.1.2' playServicesVersion = '9.2.0' gsonVersion = '2.3'} 

Журнал распечатывается через

 adb shell setprop log.tag.FA VERBOSE adb shell setprop log.tag.FA-SVC VERBOSE adb logcat -v time -s FA FA-SVC 

Я думаю, что версия, которую я сейчас использую, достаточно хороша, но я все еще получаю сообщение об ошибке, может ли кто-нибудь дать мне подсказку?

Solutions Collecting From Web of "Ошибка SERVICE_VERSION_UPDATE_REQUIRED с использованием Firebase Analytics на Android"

После публикации комментариев по этому вопросу (см. Выше), я экспериментировал с приложением, созданным с Firebase 9.2.0, на эмуляторе, имевшем старую версию Служб Google Play. Используя команды adb опубликованные в вопросе, я увидел те же предупреждения, что и в вопросе. Также в обычном logcat выводе было сообщение:

 W/GooglePlayServicesUtil: Google Play services out of date. Requires 9256000 but found 9080030 

Вам необходимо обновить Службы Google Play на своем устройстве. Если вы используете Firebase 9.2.0, требуемая версия Служебных услуг – 9.2.56.