Intereting Posts
Студия Android не обновляет новые версии Как использовать Legacy Apache в Eclipse для поддержки Android M Поля пароля RTL для Android? Выдвиньте ListView со стороны, как в новом приложении GMail Перенос ByteArray через Parcel возвращает NullPointerException Где я могу найти файл .apk на своем устройстве, когда я загружаю любое приложение и устанавливаю? Применить Touch Swipe на одной странице, странице, которая используется для динамической загрузки данных? Android studio nullpointer предупреждения / уведомление в виде кода Android Espresso: последовательное выполнение нескольких тестов Приостановка потоков при запуске нескольких AsyncTasks во вложенных фрагментах и ​​медленное приложение Сигнал R Собственное Android-приложение Не удалось выполнить переговоры Ошибка NavUtils.shouldUpRecreateTask на JellyBean GetMeasuredHeight () TextView с завернутым текстом Как создать приложение для Android с внешними библиотеками с помощью ant? Разделение Android-серверов

Отсутствует платформа SDK для Android, API 18

Пока я пытаюсь установить API 18, он показывает только "Google API 18" (не более того). Теперь, когда я пытаюсь установить эти API Google из Android SDK Manager он показывает сообщение "this package depends on "Missing SDK platform Android, API 18" и кнопка« Установка »отключена.

Кто-нибудь здесь имеет любую идею, как установить API 18 (4.3_MR2 sdk) с помощью eclipse

Solutions Collecting From Web of "Отсутствует платформа SDK для Android, API 18"

Установили ли вы платформенный инструмент Sdk версии 18. В вашем SDK-менеджере появится последняя версия инструментов SDK PlatForm, которую вы должны установить сначала, а затем перезапустите eclipse, а затем попробуйте Android SDK API 18

Введите описание изображения здесь

Сделайте это сначала:

Eclipse> Окно> Android SDK Manager> Пакеты> Перезагрузка

Затем повторите попытку установки

Другой способ ее устранения:

0) установить другие пакеты БЕЗ выбора API 18,

1) перезапустите Eclipse ADT,

2) Откройте диспетчер SDK, затем появится API 18 rev 1.

Поздно к игре, та же проблема. Инструменты SDK, а не инструменты SDK Platform, появились для меня. Это был четырехэтапный процесс:

  1. Eclipse / Справка / Проверить наличие обновлений, установить все найденное, перезапустить Eclipse
  2. Eclipse / Window / Android SDK Manager – установленный репозиторий поддержки Android (спасибо, BurDog). Закрытый менеджер SDK.
  3. Eclipse / Window / Android SDK Manager – теперь Android SDK Tools (Rev 22) появился вверху, установлен. Закрытый менеджер SDK
  4. Теперь появились инструменты Android SDK Platform Tools в разделе API 18. Перезапустить Eclipse (или API 18 будет недоступен везде).

Наконец, хорошо сделать новую версию.

У меня была такая же ситуация. Для меня работало обновление плагина ADT до версии 22.0.5, закрытие Eclipse. Затем – Eclipse> Окно> Android SDK Manager> Пакеты> Перезагрузка. Надеюсь, это поможет кому-то.

Была та же проблема. Сообщение было:

Пакет google apis android api 18 версия 1 зависит от отсутствующей платформы sdk android api 18

Я решил это следующим образом:

  1. Eclipse -> Справка -> Проверить наличие обновлений (затем нажмите «ОК», когда вас спросят – вы хотите установить его – нажмите «ok» / «yes», чтобы перезапустить eclipse, чтобы завершить установку)
  2. Окно -> Android SDK Manager -> Отменить выбор всех (затем прокрутите вниз до раздела «Дополнительно» и выберите «Репозиторий поддержки Android», если он не установлен, установите его)
  3. Window -> Android SDK Manager -> Установить пакеты xx

Отлично работал для меня.

Вот как я исправил мою:

  1. В разделе «Манифест-кэш» нажмите «Очистить кеш»,
  2. Перейдите в раздел «Пакеты» и нажмите «Обновить».
  3. Инструменты проверки -> Android SDK Platform-tools
  4. Установите только этот пакет
  5. Перезапустить диспетчер SDK

Eclipse> Окно> Android SDK Manager> Пакеты> Перезагрузка

Это сработало для меня. Благодаря! Теперь я могу обновить до 18. Я здесь новый и пытался проголосовать за пост Jaguar, но я не могу.

Казалось, что это klukey, у меня были подобные проблемы. Я, наконец, получил api 18 msg, когда я обновил инструменты sdk до 22, которые затем вызвали еще одну ошибку, что инструменты были деградированы при перезагрузке. Я снова открыл sdk mgr и имел 22.3 и платформенные инструменты для rev19 и некоторые другие доступные варианты инструментов. Я сделал еще одно обновление для них, а также API19 и API 18, и похоже, что он движется сейчас. Я думаю, что, возможно, для API 18+ вы должны обновить инструменты SDK до 22.3 на этом этапе. Кстати, у меня также есть блокировка файла во время части процесса и закрытие затмения в фоновом режиме и исправление повторных попыток. Dang .. далее говорится, что ADT должен быть версии 22.0+ ..
Я обновил ADT до 22.3 с помощью eclipse / help / install new software (Trying update просто сказал, что он обновлен) … одна неподписанная ошибка содержимого. Перезапуск ADT после обновления .. похоже, работает от того, что я могу Скажите до сих пор.

Я решил с этим:

  1. Открыть Android SDK Manager -> Пакеты -> Обновить
  2. Перезапустить Android SDK Manager
  3. Установите «отсутствующие» пакеты (теперь они видны)

У меня была эта проблема на машинах разработки Mac и Windows. Единственное решение – переустановить последнюю версию Android SDK. Google действительно сбросил мяч.

У меня была такая же проблема, как и вы (чисто из описания проблемы), но мои Android-платформы Android SDK уже установлены (16.0.2). Однако все остальные пакеты его не узнали. Я закончил удаление инструментов платформы, а затем переустановил. Тогда все остальное узнало это.

Найдено с другого сайта

Действия по устранению этой проблемы:

  1. Открыть диспетчер SDK
  2. Перейдите в Инструменты -> Параметры
  3. В разделе «Манифест-кэш» нажмите «Очистить кеш»,
  4. Затем перейдите в «Пакеты» и нажмите «Перезагрузка»,

Я на MAC, я столкнулся с тем же вопросом. Я не смог найти SDK-платформу в API 18. Решение для ее решения на mac сначала устанавливает SDK TOOLS, затем перезагружает диспетчер sdk, а затем я нашел платформу SDK в API 18.

У меня была та же проблема, но с API19 . После каждой установки я установил следующее индивидуальное закрытие Android SDK Manager (спасибо cdoner):

  • Android SDK Tools 22.3
  • Репозиторий поддержки Android 3

И тогда я смог установить API19, и он больше не выдавал ошибку. ( «Этот пакет зависит от« Missing Platform SDK Platform, API19 » )

Я решил вернуться к кодированию через 15 лет и совершенно новый для Java и Android, только прочитав книгу « Head Start Java» . Благодарим вас за легкие шаги, особенно для кого-то нового.

Я не мог установить новый SDK из Eclipse (Справка -> Установить новое программное обеспечение / Проверить наличие обновлений), он жаловался, что новая версия уже установлена. Однако новый SDK не появился в менеджере SDK.

Я решил это, установив новую версию SDK через командную строку: android update sdk –no-ui

Впоследствии появилась возможность обновлять API-интерфейсы Google и другие инструменты с помощью менеджера SDK.

Очистка кеша решена проблема для меня. (Инструменты>)

У меня была эта проблема с API 19. Ключ для меня, чтобы использовать Android SDK Manager, начиная с eclipse. Затем приведенный выше совет работал над устранением проблемы.

Справочная информация. Из-за других команд, которые я делал, я запускал диспетчер SDK, набрав в командной строке «android». – это то, о чем я уже говорил.

  1. Ему нужны минимальные пакеты sdk и max sdk.
  2. Вы только установили максимальный sdk, то есть API18 3.it также зависит от других пакетов sdk для минимальных