Intereting Posts
Как получить идентификатор фронтальной камеры с помощью Camera2? Непроверенный вызов ArrayAdapter Расширяемый список Android Ошибка Eclipse: R не может быть разрешено переменной Синхронизация с календарем Android-телефона в Календаре Google в Интернете без использования API данных календаря Google. Это возможно? Вставить null в таблицу Sqlite Есть ли способ прослушать конец анимации в AnimatedVectorDrawables Как обрабатывать изменение ориентации экрана, когда диалог выполнения и фоновый поток активны? Google cloud messaging: 100 множественных ограничений отправителей Является ли «тег» представления восстановленным, когда воссоздана активность, макет которой содержит представление? Android: Получить представление Ссылка на пункт меню Написание элементов объектов на Участки События аналитики Firebase не показывают ценность Маршрут отображения API Google Maps API v2 Как создать девять патчей и использовать их в моем приложении?

Intellij: android-support-v4.jar в составе actionBarSherlock и Project => IllegalArgumentException

В настоящее время я переношу все мои проекты из Eclipse в IntelliJ Idea.

Когда я использовал Eclipse, пакет был включен только в библиотеку ActionBarSherlock, и когда библиотека была включена в мой проект, все было автоматически добавлено.

С IntelliJ, как только андроид-поддержка-v4.jar добавляется в АБС, этого не кажется достаточно, поскольку весь мой импорт поврежден.

Скриншот импорта ActionBarSherlock (LibABS):

Введите описание изображения здесь

Все кажется прекрасным, все SherlockActivity в порядке, но все, что связано с поддержкой, не признано в моем приложении:

java: /home/user/workspace/.... cannot access android.support.v4.app.FragmentActivity class file for android.support.v4.app.FragmentActivity not found 

Итак, я должен скопировать вручную банку в папку libs и снова включить ее в мой проект.

Снимок экрана моего импорта проекта:

Введите описание изображения здесь

Импорт признан, гайка Теперь я получаю эту ошибку:

 Android Dex: [BeTrains-for-Android] UNEXPECTED TOP-LEVEL EXCEPTION: Android Dex: [BeTrains-for-Android] java.lang.IllegalArgumentException: already added: Landroid/support/v4/app/ShareCompat$ShareCompatImplJB; 

Большое спасибо за любую помощь.

Solutions Collecting From Web of "Intellij: android-support-v4.jar в составе actionBarSherlock и Project => IllegalArgumentException"