Intereting Posts
Выбранный элемент меню GridView Android КоординаторLayout перекрывается Как обновить ListView в случае использования CursorAdapter? Как добавить анимацию в DialogFragment? Ошибка InMobi при выключении тестового режима Как получить доступ к getFilesDir () как переменную среды? Google Maps Android api v2 и текущее местоположение Можно ли установить дату выпуска в магазине воспроизведения Google? Широковещательный приемник для проверки подключения к Интернету в приложении Android Может ли фаза «Обновление библиотеки Android» как-то ускориться? Создайте (повторяющийся высокий шаг) Тревога на дистанционном триггере, когда приложение не работает (iphone / android), как Find My iPhone Загрузка и сохранение изображений с помощью Picasso Как предотвратить метод onClick на прозрачной части загруженного PNG ImageView Цвет фона AndroidView WebView: прозрачный игнорируется на Android 2.2 Цель CONNECTIVITY_ACTION получена дважды при подключении Wi-Fi

Для запуска Eclipse должна быть доступна Java Runtime Environment (JRE) или Java Development Kit (JDK)

Пробовал поиск по Google, но не смог найти решение.

Использование Windows 7 Ultimate 64 бит.

У меня установлена ​​Java (64 бит): C:\Program Files (x86)\Java\jre7

Загруженный Android SDK отсюда Получите Android SDK

Я загрузил 64 бита, учитывая, что мои окна имеют 64 бита. Требуется ли 32 бит?

Теперь, когда я запускаю eclipse.exe, я получаю следующую ошибку:

Для запуска Eclipsec должна быть доступна Java Runtime Environment или JDK. Никакая виртуальная машина Java не была найдена после поиска в следующем месте: C: \ Users .. \ Downloads \ adt-bundle-windows = x86_64-3013131030 \ adt-bundle-windows-x86_64-20131030 \ eclipse \ jre \ bin \ java.exe

Извините, не можете опубликовать снимок экрана, потому что на данный момент у вас нет репутации.

И что же мне делать?
Нужно ли устанавливать 32-битную Java или загружать 32-битный SDK?

PS: Перед запуском Eclipse я запустил «SDK Manager» и установил некоторые необходимые инструменты. Может быть, если это поможет.

Solutions Collecting From Web of "Для запуска Eclipse должна быть доступна Java Runtime Environment (JRE) или Java Development Kit (JDK)"

Просто установите переменную окружения. Перейти к Свойствам компьютера -> Предварительная настройка системы -> Переменные среды -> Системные переменные -> путь и после полуколона вставить путь к вашей JRE, как это: C: \ Program Files \ Java \ jre7 \ bin щелкните по ок.

Откройте CMD и введите java, если эта команда работает правильно, значит, ваш путь уже установлен. Просто открывай вам затмение, и он будет работать на этот раз. Вы можете сделать это через командную строку, просто введите команду PATH = C: \ Program Files \ Java \ jre1.6.0_03 \ bin и нажмите клавишу ввода.

Если все же он не работает, просто вставьте этот набор PATH = C: \ Program Files \ Java \ jre1.6.0_03 \ bin в файл eclipse.ini 🙂

У вас 32-разрядная Java. «Program Files (x86)» для 32-разрядных программ в 64-битной системе. Либо установите 64-битную Java, либо загрузите ее, либо получите 32-разрядную загрузку.

Вам необходимо использовать любую из следующих конфигураций:

  1. x64 System, x64 JDK, x64 ADT Bundle
  2. x64 System, x86 JDK, x86 ADT Bundle
  3. x86 System, x86 JDK, and ADT Bundle