Eclipse сообщает об обновлении библиотеки позже, чем подключаемый модуль ADT

На новой установке Android SDK графический макет Eclipse пуст, а не показывается рендеринг макета. Eclipse отображает это сообщение:

Эта версия библиотеки рендеринга более поздняя, ​​чем версия плагина ADT. Обновите плагин ADT.

Отчет об ошибках Eclipse сообщает об обновлении библиотеки позже, чем в плагине ADT перечислены шаги для воспроизведения. Как это исправить?

Solutions Collecting From Web of "Eclipse сообщает об обновлении библиотеки позже, чем подключаемый модуль ADT"

  1. Нажмите « Справка»> «Установить новое программное обеспечение» .
  2. В поле « Работа с» введите: https://dl-ssl.google.com/android/eclipse/
  3. Выберите Инструменты разработчика / Инструменты разработки Android .
  4. Нажмите « Далее» и завершите работу мастера.

Измените версию Android в процессе рендеринга.

Введите описание изображения здесь

Изменение в API версии от 18 до 17 работает для меня.

Изменить: решение работало и для Android Studio.

Причина для предупреждения – использование старого ADT (средства разработки Android), поэтому обновите свой ADT, выполнив следующие процедуры:

Процедура 1:

  1. Внутри Eclipse Выберите меню «Справка»
  2. Выберите «Проверить обновления»
  3. Он отобразит «Необходимые обновления» в этом окне, выберите «Все параметры» с помощью флажка или выберите «Обновлено ADT».

Введите описание изображения здесь

Процедура 2:

Нажмите «Справка»> «Установить новое программное обеспечение». В поле «Работа с» введите: https://dl-ssl.google.com/android/eclipse/. Выберите инструменты разработчика / средства разработки для Android. Нажмите «Далее» и завершите работу мастера.

Я меняю API версии 17, 19, 21 и 23 в xml layoutside

&&

Обновленные средства разработки Android 23.0.7, но все равно не могут правильно отобразить макет, поэтому я обновил Android DDMS 23.0.7, он отлично работает .. !!!

Пожалуйста, попробуйте один раз удалить из справки -> Сведения об установке

И повторите попытку установки с помощью http://dl-ssl.google.com/android/eclipse/.

Измените целевую версию на новые обновления. В противном случае измените версию SDK, имеющуюся в файле манифеста Android.

 android:minSdkVersion="8" android:targetSdkVersion="18"