Intereting Posts
Используйте android.R.layout.simple_list_item_1 с легкой темой Сделайте снимок с намерением камеры и сохраните файл Состояние нажатой кнопки Android Обнаружение входящих и исходящих SMS-сообщений Не удалось отладить андроид / хром удаленно от ubuntu / linux Android adb shell – ash или ksh? Как отправить файл с устройства Android на другое устройство через Bluetooth по коду Ошибка: выполнение выполнено для задачи ': app: transformClassesWithDexForDebug' Проверка базы данных android sql из Eclipse Как использовать или обходной путь searchManager.getSearchableInfo () в Android API 7? Error: не удается найти метод символов getMap () после обновления зависимостей Что мне следует добавить в атрибут contentDescription для декоративных изображений, таких как разделитель полей? Android Studio: Gradle: ошибка: не удается найти символьную переменную Использование android.jar в проекте Java – RuntimeException Stub? Потоковое видео в реальном времени на Android

Com.google.android.maps отсутствует?

Новый для Android. Проверял часто задаваемые вопросы на сайте SDK, но не нашел ничего полезного.

Я изучаю несколько книг с загружаемым кодом. Один из примеров, которые я хотел бы запустить, даже не будет компилироваться, потому что среда IDE не может найти / импортировать библиотеку / пакет com.google.android.maps , который я нашел нечетным, так как у меня есть все возможное, что SDK предложения. Информация о книге на сайте издателя также не помогла. Есть идеи?

Я использую Eclipse (сборка 20090920-1017) с плагином ADT 0.9.5. SDK полностью обновлен (все доступные пакеты установлены, включая android 1.1 api 2 rev. 1 через android 2.0.1 api6 rev 1 и google apis 3 rev 3 – 6 rev 1.)

Любые советы приветствуются. Спасибо заранее.

Solutions Collecting From Web of "Com.google.android.maps отсутствует?"

Выберите проект «Google API». И убедитесь, что Google API установлен в вашем Android SDK.
И не забудьте добавить

<uses-library android:name="com.google.android.maps" /> 

В тег в ApplicationManifest.xml

Перейдите в «Google API», поскольку проект Build Target работает для меня.

Project-> properties-> android, проверьте API GOOGLE

  1. Установите все API google с помощью диспетчера sdk.

  2. В вашем манифесте под элементом приложения добавьте

     <uses-library android:name="com.google.android.maps" /> 
  3. Вы также должны включить файл jar для карт. Щелкните правой кнопкой мыши на своем проекте и перейдите к пути создания, а затем добавьте внешние архивы. Найдите свой sdk. android-sdk-windows\add-ons\addon_google_apis_google_inc_<your api version>\libs\maps

У меня тоже была эта ошибка, хотя я вставил

 <uses-library android:name="com.google.android.maps"/> 

Я долгое время пытался решить эту проблему …

Затем проект по очистке и восстановлению решает проблему

Помните, что всегда нужно добавлять библиотеки использования в ветви приложения. Как это:

У меня также была та же проблема, но я добавил библиотеки использования не в приложении

 <?xml version="1.0" encoding="utf-8"?> <manifest xmlns:android="http://schemas.android.com/apk/res/android" package="com.MapsTest" android:versionCode="1" android:versionName="1.0.0"> <application android:icon="@drawable/icon" android:label="@string/app_name"> <activity android:name=".MapsTest" android:label="@string/app_name"> <intent-filter> <action android:name="android.intent.action.MAIN" /> <category android:name="android.intent.category.LAUNCHER" /> </intent-filter> </activity> <uses-library android:name="com.google.android.maps"/> </application> <uses-permission android:name="android.permission.INTERNET"></uses-permission> <uses-permission android:name="android.permission.ACCESS_FINE_LOCATION"></uses-permission> <uses-permission android:name="android.permission.ACCESS_LOCATION_EXTRA_COMMANDS"></uses-permission> <uses-permission android:name="android.permission.ACCESS_COARSE_LOCATION"></uses-permission> </manifest> 

Разбирается в 0,004 секунды, используя GeSHi 1.0.8.4

Чтобы разработать с помощью Google Maps, я рекомендую использовать эмулятор eclipse вместо Genymotion .