Appcompat / добавить библиотеку с Android-студией

[Исправлено] Когда вы добавили свои зависимости, вам нужно синхронизировать свой проект. Это значок слева от значка AVD Manager

Всем привет,

Я пытаюсь использовать appcompat-v7 с андроид-студией. Я добавляю эти строки:

dependencies { compile 'com.android.support:appcompat-v7:18.0.+' } 

В build.gradle, но когда я пытаюсь импортировать lib:

 import android.support.v7.app.ActionBar; 

Он говорит мне, что не может решить v7 .. И когда я проверяю папку external lib, есть только поддержка-v4.

Я что-то пропустил ?

Ps: Он работал в другом проекте, и я мог видеть lib во внешней библиотеке, но он не хочет делать это снова.

Solutions Collecting From Web of "Appcompat / добавить библиотеку с Android-студией"

У вас должно быть две зависимости:

 dependencies { compile 'com.android.support:support-v4:18.0.+' compile 'com.android.support:appcompat-v7:18.0.+' } 

Убедитесь, что вы загрузили последнюю версию Android Support Library и Support Repository в свой менеджер SDK.

http://developer.android.com/tools/support-library/setup.html#download

Подробное руководство по настройке ActionBarActivity:

http://www.blackcj.com/blog/2013/08/14/actionbar-with-android-support-library-r18/

Чтобы добавить на blackcj Избегайте использования + в версиях, это может привести к непредсказуемым и неповторимым построениям на студии Android, это может привести к увеличению времени сборки по градиенту. Это дорого!