Какая версия Apache HttpClient используется в Android 4.2.2 SDK?

Какая версия Apache HttpClient используется в Android 4.2.2 SDK? Я проверил https://code.google.com/p/httpclientandroidlib/, но это не кажется правильным, потому что класс AuthCache должен находиться в SDK Android 4.2.2, если он использует последний HttpClient.

Solutions Collecting From Web of "Какая версия Apache HttpClient используется в Android 4.2.2 SDK?"

Какая версия Apache HttpClient используется в Android 4.2.2 SDK?

То же самое, что и в любой версии Android с самого начала. Я думаю, что официальный номер 4.0-бета-1 или, возможно, 4.0-бета-2. См. https://stackoverflow.com/a/4818714/115145 для получения дополнительной информации.

https://code.google.com/p/httpclientandroidlib/ – это рефакторинг HttpClient в новый пакет ( ch.boye.httpclientandroidlib ), чтобы он существовал на вашей виртуальной машине одновременно с более старой версией HttpClient от Android ,