Articles of java 7

Android Studio: какие настройки компилятора включены с Google Maps

Я создал новый проект в Android Studio и добавил активность Google Maps. Я получаю эти предупреждения: warning: com/google/android/gms/maps/GoogleMap.class(com/google/android/gms/maps:GoogleMap.class): major version 51 is newer than 50, the highest major version supported by this compiler. It is recommended that the compiler be upgraded. warning: com/google/android/gms/maps/SupportMapFragment.class(com/google/android/gms/maps:SupportMapFragment.class): major version 51 is newer than 50, the highest major version supported […]

Какие существуют подписи для подписания Android APK?

Отказ от ответственности: Я знаю основы подписания APK, и у меня есть проблема только с одним из моих проектов и только при подписании с Microsoft Windows в качестве ОС. Я строю свой APK с Maven и подписываю их с помощью maven-jarsigner-plugin: <plugin> <groupId>org.apache.maven.plugins</groupId> <artifactId>maven-jarsigner-plugin</artifactId> <executions> <execution> <id>signing</id> <goals> <goal>sign</goal> </goals> <phase>package</phase> <inherited>true</inherited> <configuration> <archive>target/${project.build.finalName}.apk</archive> <sigfile>CERT</sigfile> […]

Поддерживает ли ADT API Java 7

Поддерживают ли Android-разработчики JAVA 7 API до этой даты? Я пытаюсь создать Android-приложение с помощью JAVA 7, и мне было интересно об этом.

Android import java.nio.file.Files; не может быть решен

Я тестирую новый API Gmail, и образцы используют классы в пакете java.nio.file, ei Files и FileSystems . Эти классы были введены в Java jdk 1.7 для записи, и поскольку я запускаю jdk 1.7.0_65 в своем приложении для Android, я понятия не имею, почему Android Studio не может найти эти классы. Импорт: import java.nio.file.FileSystems; import java.nio.file.Files; […]

Поддерживает ли Android план поддержки Java7?

Поскольку Android в настоящее время не поддерживает java7, мне интересно, если они сделали официальный комментарий, если они работают над его поддержкой?

Поддерживает ли Android JDK 6 или 7

Я новичок в разработке Android. Могу ли я использовать существующий Java-код, разработанный с использованием JDK 7 в Android? Функции используют xerces dom и xslt и xpathapi. В настоящее время, когда я установил среду Android Eclipse ADT, эти функции не компилируются. Я также хотел бы узнать, поддерживает ли устройство Android JRE 6 или 7?

Какая версия JDK (уровень языка) требуется для Android Studio?

Я новичок в мире Android и с фоном .NET. Я пытаюсь установить Android Studio, но у меня есть несоответствие на Android.com о версии JDK, необходимой для разработки приложений для Android. На веб-странице SDK указано, что требуется JDK 6 (в разделе «Системные требования»). Джим Уилсон также настаивает на своем курсе на Pluralsight (что совсем недавно, с […]

Java-язык с поддержкой Android

Просто интересно, попробовал ли кто-нибудь использовать новые функции языка Java 7 с Android? Я знаю, что Android читает байт-код, который Java выплевывает и превращает его в dex. Поэтому, я думаю, мой вопрос в том, может ли он понять байт-код Java 7?