Articles of android wear

Android Wear Error ConnectionResult {statusCode = SERVICE_VERSION_UPDATE_REQUIRED, разрешение = null}

Я хотел сделать легкое носимое приложение и подключиться через слой данных. Все работает отлично с карманным модулем (используя: S5), но носимый (используя: Moto 360) всегда выдает ошибку: OnConnectionFailed: ConnectionResult {statusCode = SERVICE_VERSION_UPDATE_REQUIRED, разрешение = null} Игровые сервисы на КПК являются актуальными я добавил compile 'com.google.android.gms:play-services:7.3.0' Для обоих, карманный, как износ build.gradle. Носимый вид деятельности: @Override […]

Каков правильный способ реализации GridViewPager на Android Wear?

Я пытаюсь реализовать GridViewPager, поэтому я могу переключаться между двумя уникальными видами. До сих пор я вообще не мог добавлять какие-либо мнения. Ниже мой код public class Gridder extends Activity { private TextView mTextView; GridViewPager gridViewPager; @Override protected void onCreate(Bundle savedInstanceState) { super.onCreate(savedInstanceState); setContentView(R.layout.activity_gridder); final WatchViewStub stub = (WatchViewStub) findViewById(R.id.watch_view_stub); final LayoutInflater inflater = getLayoutInflater(); […]

Проблема подключения Bluetooth для Bluetooth Bluetooth

Я работал с устройством, которое на самом деле не совместимо с Google BLE и вместо этого использует Samsung BLE SDK для его подключения. Я попытался использовать SDK Google, и он может подключиться успешно, но сразу отключен со статусом 19 после подключения, в котором нет документации о том, что это за статус. 03-02 00:07:55.572 1181-1181/alex.jstylemod I/art﹕ […]

Существует ли какой-либо метод для проверки износа Android Wear или нет?

Существует ли какой-либо общий механизм для проверки того, носится ли парная Android Wear (и внутри диапазона)? Критерии износа могут быть одним или несколькими из следующих: – Износ в пределах диапазона телефона (подключен). – Имеет импульс (если устройство имеет такую ​​возможность). – Износ переместился (если устройство имеет датчик движения). Моя цель – только отправлять уведомления на […]

Режим NotificationListenerService и Doze и App Standby

У меня есть приложение, которое прослушивает уведомления по телефону и отправляет сообщение на Android Wear через MessageApi . Все работает хорошо, за исключением некоторых устройств с Android 6, особенно Huawei Mate 8 (похоже, что все Huawei Android 6 делают это). У Huawei есть своя реализация фоновой обработки замороженных приложений (защищенные приложения). Из отчетов пользователей я […]

Android Wear Google Analytics

Можно ли напрямую использовать Google Analytics с Android Wear? Смысл, могу ли я создать Tracker и т. Д. Непосредственно в моем приложении для ношения, или мне нужно отправить данные на телефон в качестве прокси-сервера для службы аналитики? ОБНОВЛЕНИЕ: Я попытался использовать Analytics непосредственно из Wearable, и до сих пор я ничего не получаю (ничего не […]

Как установить высоту элемента WearableListView

Я делаю список WearableListView. Проблема в том, что настройка android: layout_height = "20dp" не помогает Как установить высоту в этом случае? В примерах проектов Android Wear «Уведомления и таймер» они также просто установили атрибут android: layout_height = «80dp». Но я попытался установить в проектах android: layout_height = "20dp", но это не помогло! (Ниже мой исходный […]

Ошибка Gradle: конфигурация объявляет зависимость, которая не объявлена

Я делаю свое первое приложение для Android, но я не могу заставить Android Studio работать. Сначала я получил ошибку "Project with path ':wear' could not be found in project ':mobile'. Это было разрешено добавлением "include ':wear" в settings.gradle . Но затем возникает новая ошибка: "Error:Module version Test2:mobile:unspecified, configuration 'wearApp' declares a dependency on configuration 'default' […]

Adb не распознает передачу Samsung или смотреть lg g

Я пытаюсь выполнить adb на часах Samsung live watch на окнах 7. Кажется, я не нахожу драйверы устройств, чтобы распознать их adb. Это то, что у меня уже есть – Я включил adb отладочную передачу Я пошел в диспетчер устройств и указал местоположение драйвера устройства для передачи в реальном времени на sdk \ extras \ […]

APK, поддерживающие Android Wear, должны иметь минимальную версию SDK не менее 23

Я получил эту ошибку при загрузке APK в GooglePlay: «APK, поддерживающие Android Wear, должен иметь минимальную версию SDK как минимум 23, этот APK имеет 20." Как мое приложение для мобильных приложений, так и ношение имеют минимальные SDK, установленные на 20. У меня никогда не возникало проблем с обновлением моего приложения ранее, это, как представляется, новое […]

Intereting Posts