Articles of Android studio

Добавление локальных файлов .aar в сборку Gradle с использованием «flatDirs» не работает

Я знаю об этом вопросе: добавление локальных файлов .aar в мою сборку gradle, но решение для меня не работает. Я попытался добавить это заявление на верхний уровень моего файла build.gradle : repositories { mavenCentral() flatDir { dirs 'libs' } } Я также помещал файл slidingmenu.aar в /libs и ссылался на него в разделе dependencies : […]

Как импортировать проект андроида в качестве библиотеки и НЕ компилировать его как apk (Android studio 1.0)

Я попытался импортировать проект (projLib) в качестве зависимости для другого проекта (projAPK). ProjAPK gradle имеет следующее: dependencies { compile project(':libs:NewsAPI') compile project(':projLib') } Но когда я синхронизирую градир, он дает эту ошибку: Ошибка: зависимость Android_2015: projLib: неопределенный в проекте projAPK разрешает архив APK, который не поддерживается как зависимость от компиляции. Файл: /Users/myname/Documents/Development/Android_2015/libs/projAPK/build/outputs/apk/projLib-release-unsigned.apk Поэтому я предполагаю, […]

Студия Android Studio занимает слишком много времени для создания

Мой проект Android Studio использовался для сборки быстрее, но сейчас требуется много времени для его создания. Любые идеи, что может вызвать задержки? Я пробовал https://stackoverflow.com/a/27171878/391401, но никакого эффекта. У меня нет антивирусной программы, которая может прервать сборку. Мое приложение не так велико по размеру (около 5 МБ ), и оно использовалось для сборки в течение […]

Андроидная студия 0.4.2: ошибка сбоя проекта Gradle

После обновления до 0.4.2 я получаю эту ошибку при открытии проекта: «Синхронизация проекта Gradle не удалась. Базовая функциональность (например, редактирование, отладка) не будет работать должным образом " Журнал событий показывает это: Error occurred during initialization of VM Could not reserve enough space for object heap Error: Could not create the Java Virtual Machine. Error: A […]

Папка Android SDK занимает много места на диске. Нужно ли сохранять все системные изображения?

На моем диске в папке android sdk накладывается много системных образов . Я вряд ли использую эмулятор. Может быть раз в 6 месяцев. Большая часть моего развития находится непосредственно на устройстве. То, что я хотел проверить, – удалить системные образы (по крайней мере для старого APIS, т. Е. <22), повлиять на разработку? Кроме того, в […]

Все библиотеки com.android.support должны использовать ту же самую спецификацию версии

После обновления до android studio 2.3 я получил это сообщение об ошибке. Я знаю, что это просто подсказка, поскольку приложение работает нормально, но это действительно странно. Все библиотеки com.android.support должны использовать ту же самую спецификацию версии (версии для микширования могут привести к сбоям во время выполнения). Найдено версии 25.1.1, 24.0.0. Примеры включают com.android.support:animated-vector-drawable:25.1.1 и com.android.support:mediarouter-v7:24.0.0 […]

Плагин слишком стар, обновите его до более поздней версии или установите переменную окружения ANDROID_DAILY_OVERRIDE в

Сегодня я просто импортировал пример приложения из Android SDK в качестве модуля в свой проект (аналитика), и вдруг я получил эту ошибку градиента, когда я пытаюсь ее синхронизировать: Plugin is too old, please update to a more recent version, or set ANDROID_DAILY_OVERRIDE envrinment variable to… Это файл моего приложения: apply plugin: 'com.android.application' android { compileSdkVersion […]

Как установить дом с градиентом при импорте существующего проекта в студию Android

Как установить gradle home при импорте существующего проекта в студию Android. При попытке импорта мне нужно настроить этот путь.

HttpClient не будет импортироваться в Android Studio

У меня есть простой класс, написанный в Android Studio: package com.mysite.myapp; import org.apache.http.client.HttpClient; public class Whatever { public void headBangingAgainstTheWallExample () { HttpClient client = new DefaultHttpClient(); } } И из этого я получаю следующую ошибку времени компиляции: Cannot resolve symbol HttpClient Не включен ли HttpClient в Android Studio SDK? Даже если это не так, […]

Изменение уровня API Android Studio

Я хочу изменить минимальную версию SDK в Android Studio от API 12 до API 14. Я попытался изменить ее в файле манифеста, т. Е. <uses-sdk android:minSdkVersion="14" android:targetSdkVersion="18" /> И восстановление проекта, но я до сих пор получаю Android Studio IDE, вызывая некоторые ошибки. Я полагаю, что мне нужно установить минимальный SDK в «свойствах проекта» или […]

Intereting Posts