Articles of Android studio

Android-студия – приложение с библиотечным проектом не может построить

У меня возникли серьезные проблемы с попыткой создать проект для моего приложения. У меня есть основной модуль приложения и модуль проекта библиотеки, как показано ниже: Это gradle.build для каждого из модулей: Главное приложение: buildscript { repositories { mavenCentral() } dependencies { classpath 'com.android.tools.build:gradle:0.6.+' } } apply plugin: 'android' repositories { mavenCentral() } android { compileSdkVersion […]

Android Gradle DexException: несколько файлов dex определяют Lorg / hamcrest / Описание

Com.android.dex.DexException: несколько файлов dex определяют Lorg / hamcrest / Описание При попытке выполнить отладочную сборку / тестирование либо через Android Studio, либо через Gradle в командной строке моего приложения. hamcrest релиза (без тестов) работает нормально, но как только тестирование включено ( hamcrest является тестовой библиотекой), сборка завершается с ошибкой выше. Я проверил свои зависимостей в […]

Как использовать инструменты: overrideLibrary с несколькими библиотеками

Я хотел бы создать проект Android, который совместим, например, с уровнем API 4, но все же хотел бы протестировать его с помощью UiAutomator, для которого требуется уровень API 18 на более новых устройствах. Таким образом, приложение также будет работать на старых устройствах, но автоматические тесты будут выполняться на новых устройствах. Поэтому я создал новый проект […]

Android studio Ошибка «Неподдерживаемые модули обнаружены: компиляция не поддерживается для следующих модулей»

Я использую Android studio 1.0.1. У меня есть модуль java, упомянутый другими модулями в моем проекте. Я проверил это из SVN. Но теперь каждый Неподдерживаемые модули обнаружены: компиляция не поддерживается для следующих модулей:. К сожалению, в одном проекте вы не можете иметь модули Java без модуля Gradle и модули Android-Gradle. После получения этой ошибки AS […]

Получение ошибки «Repositroy test failed» при клонировании репозитория из Gitlab в Android Studio?

Я хотел бы клонировать мой код андроида из репозитория gitlab в Android Studio 0.8.1.I зарегистрирован в VCS. >> Checked from Version Control >> Git >> Добавлен HTTP-url здесь. Он подскажет мне, что «Repositroy test failed». Пожалуйста, помогите мне разобраться в проблеме. Я также проверил плагины. Спасибо большое.

Как использовать ароматы с разными именами приложений в студии Android?

На моем уровне сборки build.gradle у меня есть следующие варианты: productFlavors { originalFlavour{ } freeFlavour{ } } Дело в том, что для создания обоих вариантов я получаю одно и то же имя приложения. Вместо этого я хотел бы иметь разные имена приложений для каждого вкуса. Было бы полезно добавить суффикс. Надеюсь, кто-то может мне помочь. […]

Gradle build-info.xml не найден для приложения модуля в Android Studio

Gradle build-info.xml не найден для приложения модуля. Пожалуйста, убедитесь, что вы используете gradle plugin gradle: 2.0.0-alpha или больше Я использую плагин gradle в gradle: 2.0.0-beta2. Я случайно получаю это предупреждение, и после этого очень часто либо приложение не обновляется, либо сбой. Достаточно очистить и перестроить, чтобы исправить проблему. Есть ли лучший способ исправить это?

UnsupportedMethodException Android Studio 0.8.9

У меня Android Studio 0.8.9. До сих пор он мог успешно синхронизироваться с файлами градации, но сегодня, когда я открыл его, он дает мне эту ошибку: UnsupportedMethodException Failed to set up Android modules in project 'Project': Unsupported method: SourceProvider.getJniDirectories(). The version of Gradle you connect to does not support that method. To resolve the problem […]

Обновление Android Studio Gradle до версии 0.5.0 – Gradle Migrating От 0,8 до 0,9 – Также обновление для Android Studio до 0.8.1

После сообщения об обновлении: Failed to refresh Gradle project 'XXX' The project is using an unsupported version of the Android Gradle plug-in (0.8.3). Version 0.9.0 introduced incompatible changes in the build language. Please read the migration guide to learn how to update your project. Такая же проблема после обновления до Android Studio до версии> = […]

Android Studio Update 0.4.0 не удалось найти buildConfig ()

После обновления Android Studio до версии 0.4.0 у меня появилась новая ошибка: Я повысил уровень 1.9 до уровня gradle-wrapper.properties distributionUrl=http\://services.gradle.org/distributions/gradle-1.9-all.zip И обновил версию gradle в build.gradle dependencies { classpath 'com.android.tools.build:gradle:0.7.+' } Теперь мой проект снова строится. У меня есть некоторые константы String, определенные для разных productFlavors: productFlavors { local { buildConfig "public static final String […]