Articles of android sdk 2.3

Файл Android.bat отсутствует в папке sdk \ tools, также у меня нет менеджера AVD и SDK в инструментах, поэтому я могу их заменить

Я также скопировал файл android.bat из моего резервного SDK, но он все еще не работает. заранее спасибо.

Почему ориентация эмулятора имбирных пряников застревает в приложениях?

Сначала я подумал, что это проблема с моим приложением, но похоже, что это происходит в любом приложении (хотя это интересно, а не на главном экране) в эмуляторе имбирных пряников. Чтобы воспроизвести мою проблему, откройте eclipse и запустите эмулятор android для пряников (я использую «API Google API-API 9» в качестве моей цели) Таким образом, процедура дублирования […]

Обновлено до версии SDK 2.3 – теперь эмуляторы не имеют возможности подключения

Я обновил с 2.2 до 2.3. Первоначально я думал, что у меня возникла проблема с тем, что мое приложение Google Maps не работает, и разместил текст ссылки на вопрос Теперь я понимаю, что проблема намного шире, поскольку не встроенные приложения, присутствующие при создании нового AVD, будут работать. Например, приложение «maps» дает «Сбой сети» – для […]

Какая версия API для Android 2.3.6?

Мне нужно сделать приложение для android 2.3.6. Какой SDK я должен использовать? Менеджер SDK только показывает 2.3.3 API 10 как самый высокий.

Android-эмулятор: не удалось получить ошибку wglGetExtensionsStringARB

Я получаю эту ошибку в журналах эмулятора Android, так как я обновил SDKManager и ADT: [2012-07-10 15:51:23 – Emulator] не удалось получить wglGetExtensionsStringARB Что это значит? И что я могу с этим поделать?

Ошибка студии Android: произошла ошибка при попытке вычислить требуемые пакеты

Я пытаюсь установить последнюю версию Android Studio на MacBook Pro 2015 К сожалению, я получаю эту ошибку: Произошла ошибка при попытке вычислить требуемые пакеты. Вот скриншот об ошибке: Что не очень информативно. Что вызывает проблему? РЕДАКТИРОВАТЬ Это исключение я получаю, когда я запускаю приложение с терминала: [ 33666] WARN – e.wizard.InstallComponentsPath – Dependant package with […]

Android Development Tool 23.0.0 и Android L Ошибка обновления в eclipse

Я обновил свой SDK с последней версией Android L и перезапустил свое eclipse, то есть работал на ADT V.22 . Но когда я проверяю обновление от Hep -> Check for updates , он говорит, что No updates were found . Я вручную попытался загрузить пакет ADT с официального сайта и попытался установить ADT-23.0.0.zip из Help […]

Запуск активности из сервиса после нажатия кнопки HOME без задержки 5 секунд

Я столкнулся с проблемой, описанной в этой проблеме с Android: http://code.google.com/p/android/issues/detail?id=4536 Проще говоря, после нажатия кнопки HOME, андроид не позволяет службам и широковещательным приемникам вызывать startActivity в течение 5 секунд. Я также заметил, что (ну, теоретически), имея следующее разрешение: "android.permission.STOP_APP_SWITCHES" Позволяет вам вызвать resumeAppSwitches (который определен в ActivityManagerService). Если посмотреть на последнюю версию ActivityManagerService, этот […]

Не удалось найти adb.exe – после обновления до Android SDK 2.3

Я обновил свой Android SDK до версии 2.3 и Android Development Tools 8.0.0. Теперь в Eclipse появляется сообщение об ошибке: Не удалось найти C: \ Program Files (x86) \ Android \ android-sdk-windows \ platform-tools \ adb.exe! И у меня нет этого файла. Как я могу это исправить? Это ошибка в Android SDK 2.3 или Android […]

Не удалось разрешить целевое «андроид-16»

Я использую Android 4.2.2. После установки последнего SDK, когда я открываю eclipse, я мог видеть, что все проекты имеют проблемы во время сборки. Ниже приводится ошибка, которую я получаю. Пожалуйста, дайте мне знать, как это решить? Unable to resolve target 'android-16'