Articles of adt

Как очистить ложные ошибки в eclipse?

Время от времени в eclipse с помощью ADT я получаю ошибки, которые остаются даже после того, как я удаляю код нарушения; На самом деле, они остаются, даже если я удаляю весь контент файла, как показано на этом снимке экрана: Ошибка – ошибка Syntax error on token "}", delete this token Достаточно сказать, что такого маркера […]

Ошибка Eclipse ADT: не удается запустить программу adb

Я на Ubuntu и просто установил Android SDK (только «SDK Only») для 64-битного Linux. Затем я установил плагин ADT для Eclipse. Когда я перезапустил Eclipse, он попросил меня открыть диспетчер SDK и установить некоторые SDK для ОС, поэтому я установил некоторые инструменты для разработчиков и самые последние (я считаю, что это был 4.2.2) Android-дистрибутив. Затем […]

ADT Bundle для Windows 7 64-битная пропавшая папка JRE и не запускается – я пробовал

Поэтому я загрузил 64-битную версию ADT Bundle с сайта developer.android.com, а что нет, но когда я запускаю eclipse (из этого пакета – это не попытка добавить подключаемый модуль в существующую IDE, это всего лишь пакет) Он говорит мне, что я не вижу javaw.exe в пути для adt … \ eclipse \ jre \ bin \ […]

Проблема эмулятора после нового обновления ADT

Привет после обновления до ADT 12 сначала выглядел нормально, тогда у меня появились такие проблемы: Эмулятор запускается неправильно и дает проблему, о которой я сообщаю ниже Я попытался использовать быстрый код из окон XML, и он смешивает кодолингу, с кем сталкиваются те же проблемы. Это ошибка, которую я получил в консоли после попытки запуска проекта […]

Не удалось запустить Android Virtual Device Manager «android avd», получая NullPointerException

Получение исключения NullPointer при попытке запустить avd. Я только что загрузил пакет ADT для Mac и запустил avroid. Кто-нибудь знает, почему это провалится? $ ./android avd java.lang.NullPointerException at com.android.sdklib.internal.avd.AvdInfo.getDeviceName(AvdInfo.java:158) at com.android.sdkuilib.internal.repository.ui.DeviceManagerPage.fillDevices(DeviceManagerPage.java:497) at com.android.sdkuilib.internal.repository.ui.DeviceManagerPage.fillTable(DeviceManagerPage.java:357) at com.android.sdkuilib.internal.repository.ui.DeviceManagerPage.createContents(DeviceManagerPage.java:259) at com.android.sdkuilib.internal.repository.ui.DeviceManagerPage.<init>(DeviceManagerPage.java:130) at com.android.sdkuilib.internal.repository.ui.AvdManagerWindowImpl1.createDeviceTab(AvdManagerWindowImpl1.java:210) at com.android.sdkuilib.internal.repository.ui.AvdManagerWindowImpl1.createContents(AvdManagerWindowImpl1.java:193) at com.android.sdkuilib.internal.repository.ui.AvdManagerWindowImpl1.open(AvdManagerWindowImpl1.java:133) at com.android.sdkuilib.repository.AvdManagerWindow.open(AvdManagerWindow.java:94) at com.android.sdkmanager.Main.showAvdManagerWindow(Main.java:369) at com.android.sdkmanager.Main.doAction(Main.java:311) at com.android.sdkmanager.Main.run(Main.java:119) at com.android.sdkmanager.Main.main(Main.java:102)

«Intent не может быть разрешен к ошибке типа в eclipse

Я программирую первый учебник по Android в eclipse и при компиляции этого кода: Intent intent = getIntent(); Он дает ошибку Намерение не может быть разрешено для типа Как это исправить?

Где можно загрузить более старую версию Android SDK?

Я хочу загрузить более старую версию Android SDK: 21.0.0, Где я могу это сделать? В настоящее время у меня есть latest version SDK для Android, загруженная из ЗДЕСЬ . Однако, я хочу более старую версию, можно ли загрузить полную старую версию SDK из любого места? Я пытаюсь получить более старую версию с помощью SDK manager […]

Внутри проекта Eclipse Android запускаются классы Java с основными (String args), поскольку приложение Java вызывает «Недопустимый макет java.lang.String at value»

Внутри проекта Eclipse Android как запускать классы Java с основными (String [] args) в качестве приложения Java? public class JavaApp { public static void main(String[] args) { // some dummy operations here, possibly including // System.out.print(string); } } Я получаю ошибку Invalid layout of java.lang.String at value # # A fatal error has been detected […]

Требуется версия Android ADT 20.0.0 и выше

Вчера я попытался установить titanium appcelerator, и в этом процессе я отредактировал некоторые установки android sdk. Теперь я обновил свой Android-файл sdk до версии 20. Но когда я запустил eclipse, я получаю сообщение об ошибке, которое требуется sdk для версии 20.0.0 или выше. Я попытался установить с помощью eclipse-> help-> check для обновлений->, но снова […]

Поддержка Google adt / gwt для eclipse 4.4 (Luna)

Кто-нибудь получил версию eclipse 4.4 для работы с adt (разработка Android) и / или google web toolkit (gwt). Похоже, что плагины gwt / adt не работают с eclipse 4.4, так что есть секретное место для загрузки новых версий или я должен продолжать использовать 4.3 – ( Изменить: причина, по которой я думал, что ADT не […]