Articles of Андроидное

Как добавить источник «Частных библиотек Android» в ADT eclipse?

Я пытаюсь увидеть исходный источник android-support-v4.jar и получить: «Ящик этого файла класса принадлежит контейнеру и« Частным библиотекам Android », Где можно получить и добавить источник «Частные библиотеки Android»?

Как решить «Этот элемент не имеет прикрепленного источника и Javadoc не может быть найден в прикрепленном Javadoc»?

Я не получаю точный метод для этого. Я хочу, чтобы метод не для одного проекта для всех проектов в eclipse. Скажите, пожалуйста, как решить эту проблему.

Доступ к ресурсам в проекте тестирования Android

Я setup проект испытания android испытания junit. Он использует два проекта eclipse «Приложение» и «ApplicationTest», где мои тесты находятся в проекте «ApplicationTest». В одном из моих тестов мне нужно получить доступ к файлу, это отлично работает, если я поместил файл на SD-карту и натолкнул на него объект File. Однако я хотел бы получить доступ к […]

Как поддерживать платную и бесплатную версию приложения

Я создал бесплатную версию игрового приложения, которое теперь находится на рынке с именем com.mycompany.myfreegame. Теперь я хочу сделать платную версию. Несомненно, будут исправления и исправления ошибок для обеих версий, требуемых на долгие годы, поэтому я хочу инкапсулировать кодировку бесплатной и оплаченной информации как можно компактнее, чтобы я мог по существу исправлять ошибки в обеих версиях […]

Как создается действие Android (используя отражение)?

Об этом сегодня в интервью для Android. Я ответил обычным, вы знаете, намерение + startActivity и т. Д. Затем собеседник спросил более остро, «Да, но где он фактически создан ? Вы не называете новую деятельность нигде». Что теперь, когда я думаю об этом, я действительно не знаю. Он намекнул, что использует отражение Java, но у […]

Охват тестового кода Android, Eclipse

Есть ли способ запуска модульных тестов для Android от Eclipse таким образом, чтобы обеспечить код и измерить охват тестового кода? Я ищу простой способ узнать, какие части моего приложения еще не проверены, исправить тестовые примеры и посмотреть, помогло ли это.

Для протокола Parcelable требуется объект Parcelable.Creator, называемый CREATOR (у меня есть CREATOR)

Я пытаюсь передать Parcelable данные от одного намерения к другому, и это ошибка, которую я получаю: 08-31 14:12:22.709: E/AndroidRuntime(9931): FATAL EXCEPTION: main 08-31 14:12:22.709: E/AndroidRuntime(9931): java.lang.RuntimeException: Unable to start activity ComponentInfo{com.matejsoftware.cardscoretracker/com.matejsoftware.cardscoretracker.Igra}: android.os.BadParcelableException: Parcelable protocol requires a Parcelable.Creator object called CREATOR on class com.matejsoftware.cardscoretracker.Novaigra$Player Дело в том, что у меня есть объект Parcelable.Creator. Я отправлю весь […]

Ошибка при запуске первого тестового приложения: проблема упаковки Android?

Conversion to Dalvik format failed: Unable to execute dex: wrapper was not properly loaded first [project] Android Packaging Problem Я никогда не работал с Java или eclipse раньше, я следую этому вводному руководству, и все поиски через google не возвращают полезные результаты. Я предполагаю, что проблема в том, что я создал Android-материал с eclipse правильно, […]

Weird Overlay рисует поведение при масштабировании MapView

Я расширил Overlay и выполнил draw() , чтобы нарисовать некоторые вещи на карте. Когда масштабирование выполняется с помощью mapController.zoomIn() (вызывается при двойном переводе карты), наложение правильно рисуется на карте. Но всякий раз, когда я увеличиваю / уменьшаю масштаб с помощью встроенного контроллера масштабирования, наложение не нарисовано должным образом, и для того, чтобы обновить оверлей, требуется […]

Проект ссылается на атрибуты RTL, но явно не включает и не отключает поддержку RTL

В файле манифеста Eclipse я получаю предупреждающее сообщение. Язык приложения – турецкий (не справа налево). «Проект ссылается на атрибуты RTL, но явно не включает или отключает поддержку RTL с помощью android: поддерживает Rtl в манифесте" Я не могу добавить android: поддерживает строку Rtl, потому что моя min sdk versionn равна 9. Это предупреждение важно? благодаря

Intereting Posts