Articles of компилятор ошибки

Не удалось найти ошибку * .apk

[2011-06-22 23:55:09 – main] Android Launch! [2011-06-22 23:55:09 – main] adb is running normally. [2011-06-22 23:55:09 – main] Could not find main.apk! Я новичок в разработке Android и застрял в очень странной ошибке. Когда я скомпилирую свое приложение для Android, я получаю вышеуказанную ошибку. Позавчера приложение работает красиво. Заранее спасибо.

Gradle (Android Studio) не будет компилировать 9 патчей

У меня проблема, я не могу скомпилировать этот 9patch с Android Studio. Это приложение Google Play Music, поэтому оно должно работать. Я сделал его 9patch с «draw9patch.bat» из инструментов Androird SDK. Но я получаю только эту ошибку: «Gradle: нет заметной области, найденной вдоль края. – Найдена вдоль верхнего края». Любая помощь будет оценена! Заранее благодарен […]

Android Dex: Невозможно выполнить DX

Когда я компилирую свой проект, я получаю такие ошибки; Ошибка: Android Dex: [OdeAl] Не удалось выполнить DX Ошибка: Android Dex: [OdeAl] com.android.dex.DexException: несколько файлов dex определяют Landroid / support / v4 / accessibilityservice / AccessibilityServiceInfoCompat $ AccessibilityServiceInfoVersionImpl; Ошибка: Android Dex: [OdeAl] на com.android.dx.merge.DexMerger.readSortableTypes (DexMerger.java:594) Ошибка: Android Dex: [OdeAl] на com.android.dx.merge.DexMerger.getSortedTypes (DexMerger. Java: 552) Ошибка: Android […]

Ошибка libpng: не файл PNG

Я несколько раз пытался обновить инструменты сборки Android Studio до версии 1.3.1, но я всегда получаю эту ошибку libpng. Я решил одну из ошибок, полностью удалив зависимость maven (так как консоль градиента указала точно, где находится файл проблемы), но теперь я застрял с той же ошибкой и не указал, где находится файл проблемы. Я что-то […]

Java.lang.NoClassDefFoundError: android.support.v7.appcompat.R $ стиль

Я разрабатываю приложение для Android. Я использую AppCombat Theme, и когда я запускаю свою программу, у меня есть java.lang.NoClassDefFoundError: android.support.v7.appcompat.R$styleable . Его журналы: Process: com.nomad, PID: 12866 java.lang.NoClassDefFoundError: android.support.v7.appcompat.R$styleable at android.support.v7.app.ActionBarActivityDelegate.onCreate(ActionBarActivityDelegate.java:107) at android.support.v7.app.ActionBarActivityDelegateICS.onCreate(ActionBarActivityDelegateICS.java:58) at android.support.v7.app.ActionBarActivity.onCreate(ActionBarActivity.java:98) at com.telera.ui.activities.OABaseActivity.onCreate(OABaseActivity.java:47) at android.app.Activity.performCreate(Activity.java:5231) at android.app.Instrumentation.callActivityOnCreate(Instrumentation.java:1087) at android.app.ActivityThread.performLaunchActivity(ActivityThread.java:2159) at android.app.ActivityThread.handleLaunchActivity(ActivityThread.java:2245) at android.app.ActivityThread.access$800(ActivityThread.java:135) at android.app.ActivityThread$H.handleMessage(ActivityThread.java:1196) at android.os.Handler.dispatchMessage(Handler.java:102) at android.os.Looper.loop(Looper.java:136) at android.app.ActivityThread.main(ActivityThread.java:5017) […]

Ошибка компиляции студии Android «Содержимое не допускается в прологе»

Я использую последнюю версию Android Studio 0.8.4 (для OS X), в директории «res» Я создаю новую папку «database» и помещаю туда все файлы, что мне нужно, и когда я пытаюсь скомпилировать, я получаю эту ошибку. Error:Content is not allowed in prolog. :app:mergeDebugResources FAILED /Users/filipp/data/Android_dev/project/app/src/main/res/database/5clSubject0Book0.txt Error:Error: Content is not allowed in prolog. Error:Execution failed for task […]

Ошибки компоновщика в Android NDK (неопределенная ссылка на `__cxa_end_cleanup ')

Я получаю этот результат после добавления в набор кода от коллеги: ./obj/local/armeabi/objs/jniWrapper/native.o: In function `_Vector_base': D:/opt/android-ndk/sources/cxx-stl/stlport/stlport/stl/_vector.h:73: undefined reference to `__cxa_end_cleanup' ./obj/local/armeabi/objs/jniWrapper/native.o:(.ARM.extab.text._ZNSt6vectorIhSaIhEEC1ERKS1_[std::vector<unsigned char, std::allocator<unsigned char> >::vector(std::vector<unsigned char, std::allocator<unsigned char> > const&)]+0x0): undefined reference to `__gxx_personality_v0' ./obj/local/armeabi/objs/jniWrapper/native.o: In function `std::__node_alloc::deallocate(void*, unsigned int)': D:/opt/android-ndk/sources/cxx-stl/stlport/stlport/stl/_alloc.h:161: undefined reference to `__cxa_end_cleanup' ./obj/local/armeabi/objs/jniWrapper/native.o:(.ARM.extab.text._ZNSt4priv12_String_baseIcSaIcEED2Ev[std::priv::_String_base<char, std::allocator<char> >::~_String_base()]+0x0): undefined reference to `__gxx_personality_v0' ./obj/local/armeabi/objs/jniWrapper/native.o: In function […]

Ошибка: атрибут «тема» уже определен

Я использую Android-студию для создания приложения. Я использую следующие зависимости: compile 'com.google.android.gms:play-services:5.2.08' сервисы: compile 'com.google.android.gms:play-services:5.2.08' App combat v7: compile 'com.android.support:appcompat-v7:21.0.0' Поддержка Cardview: compile 'com.android.support:cardview-v7:21.0.0' Поддержка Recycler view: compile 'com.android.support:recyclerview-v7:21.0.0' При создании моего приложения возникает следующая ошибка: app/build/intermediates/exploded-aar/com.google.android.gms/play-services/5.2.08/res/values/wallet_attrs.xml Error:Attribute "theme" has already been defined Code Styles.xml <resources> <!– Base application theme. –> <style name="AppTheme" parent="Theme.AppCompat.Light.DarkActionBar"> <!– […]

Android Lint ошибочно думает, что версия для SDK min 1

Eclipse отказывается строить мой Android-проект. В проводнике пакетов корневой узел проекта имеет маленький красный символ ошибки, но ничто другое внутри него не имеет этого символа. На вкладке «Проблемы» отображаются ошибки, обнаруженные Lint: Call requires API level 3 (current min is 1): android.os.AsyncTask#<init> Call requires API level 3 (current min is 1): android.view.GestureDetector#<init> Call requires API […]

GetSupportFragmentManager (). GetFragments () показывает ошибку времени компиляции

Вызов getSupportFragmentManager().getFragments() показывает ошибку времени компиляции с сообщением ниже: GetSupportFragmentManager (). GetFragments () может быть вызван только из той же группы библиотек (groupId = com.android.support) Я импортировал следующие классы в MainActivity : import android.os.Bundle; import android.support.annotation.NonNull; import android.support.design.widget.BottomNavigationView; import android.support.v4.app.Fragment; import android.support.v4.app.FragmentManager; import android.support.v4.app.FragmentTransaction; import android.support.v7.app.AppCompatActivity; import android.util.Log; import android.view.MenuItem; import android.widget.Toast; MainActivity расширяет AppCompatActivity […]

Intereting Posts
Какова самая надежная библиотека HTTP для Android? Android Paint.setTypeface не работает для курсива Более подробное объяснение procstats для Android Кликаемое изображение – андроид Ошибка загрузки приложения Google Play Android: внедрить предложение поиска приложений на основе ответа сервера Как я могу получить правильное внешнее хранилище на Samsung и всех других устройствах? Можете ли вы определить фильтр намерений Android, используя строковый ресурс? Как установить заголовок авторизации (OAuth токен) в запросе OKHTTPClient для Android Android-пользовательский ListView с ImageButton не получает фокус Автоматическая загрузка при подключении зарядного устройства к стене Дизайн материалов. Что означает «использовать оттенок 700»? Android-эмулятор не будет закрыт Расширенное отслеживание электронной торговли Google Analytics для Android Как настроить учетные данные Google Диска в приложении Android?