Выберите «Android XX» или «API Google» в новом проекте

Я думаю, что это в основном то же самое, но какую цель сборки я должен выбрать? Или между ними действительно разница?

Например, «Android 2.2» или «API Google» для одного и того же уровня платформы и API?

Eclipse Build Целевой селектор

Solutions Collecting From Web of "Выберите «Android XX» или «API Google» в новом проекте"

Если приложение использует API Google, например Google Maps, вам понадобится версия API Google. Я не сталкивался с коммерческим устройством, которое не включает эту сборку, но исходный Android с открытым исходным кодом не включает API Google, поскольку он содержит проприетарный не открытый исходный код из Google.

Если вы не используете какой-либо из этих API, не имеет значения, какой из них вы выберете. Но если вы используете какой-либо из Google Apis, вы должны использовать сборку google.

Для некоторых вещей это будет иметь значение, если вы выберете новый API, вам нужно быть осторожным, какие методы вы используете в своей программе.

Если вы используете новый метод 3.2 и не существует в более старых API, ваше приложение не будет работать на старых устройствах … если вы не делаете исключений