Импорт android.support.v7.app.MediaRouteActionProvider не может быть разрешен

Я пытаюсь использовать GoogleMap V2. Но я получаю ошибку при импорте:

import android.support.v7.app.MediaRouteActionProvider; import android.support.v7.media.MediaRouteSelector; import android.support.v7.media.MediaRouter; import android.support.v7.media.MediaRouter.RouteInfo; 

И ошибка

 The import android.support.v7.app.MediaRouteActionProvider cannot be resolved 

Вот скриншот библиотеки, которую я добавил

Введите описание изображения здесь

Что я должен делать. Я попытался импортировать android \ support \ v7 По пути сборки. Но он не разрешает мою проблему там каким-либо образом, чтобы я мог разрешить эти ошибки.

Solutions Collecting From Web of "Импорт android.support.v7.app.MediaRouteActionProvider не может быть разрешен"

Похоже, вы добавили gridlayout.jar в папку проектов lib.

Его проект библиотеки с ресурсами. Вы должны ссылаться на проект библиотеки в своем проекте андроида

Эта библиотека находится в каталоге <sdk>/extras/android/support/v7/gridlayout/ после загрузки библиотек поддержки Android.

Следуйте за добавлением библиотек с ресурсами

http://developer.android.com/tools/support-library/setup.html#libs-with-res

Имел ту же проблему и обнаружил, что ссылка в моем проекте на проект appcomcat_v7 нарушена (щелкните правой кнопкой мыши проект и выберите свойства, затем перейдите на вкладку Android) …

Я удалил, а затем добавил правильный проект, и я был готов пойти …

Введите описание изображения здесь

Такие ошибки обычно возникают, когда мы случайно закрываем эти библиотеки (с помощью близких несвязанных проектов и т. Д.), Которые автоматически генерируются в Project Explorer Eclipse, например:

  • appcompat_v7
  • appcompat_v7_2
  • appcompat_v7_3
  • appcompat_v7_4
  • appcompat_v7_5
  • appcompat_v7_6
  • appcompat_v7_7
  • appcompat_v7_8
  • appcompat_v7_9
  • appcompat_v7_10
  • appcompat_v7_11
  • appcompat_v7_12
  • appcompat_v7_13
  • appcompat_v7_14

Как только я открою эти файлы, все ошибки в моем приложении исчезли!

Если он до этого не работал, тогда Project -> Properties -> Android -> Is Library -> Add.. -> And add appcompat_v7_*

У меня была очень схожая проблема с этим после того, как я использовал силу, чтобы закрыть Eclipse.

Когда я перезапустил Eclipse, я заметил несколько папок «appcompat_v7 …» в моем каталоге рабочей области. Я удалил их – и, возможно, это и стало причиной этой проблемы.

Но я решил это, создав новый тестовый проект в Eclipse, а затем перезапустив Eclipse, чтобы снова найти все мои проекты! 🙂

Мне не нужно было менять какие-либо свойства проекта.

Это решение сработало для меня:

Поддержка библиотеки android-support-v4.jar вызывает этот конфликт, и вы видите ошибку: The import android.support.v7.app.MediaRouteActionProvider cannot be resolved , просто удалите библиотеку в папке / libs вашего проекта, потому что библиотека уже appcompat_v7 в библиотеке appcompat_v7 , очищают и строят ваш проект, и ваш проект будет работать как шарм!

Введите описание изображения здесь