Intereting Posts
Android всеобъемлющей отказоустойчивой музыкальной службы на нескольких мероприятиях Android – как отправлять отчеты о сбоях? Запись звонков – заставить работать Nexus 5X (возможно создание корневого или пользовательского ПЗУ) Странная запись в журнале, связанная с webcoreglue в android Получить все установленные иконки приложений в Android: java.lang.ClassCastException Как использовать панель инструментов для реагирования на собственное приложение для Android Быстрый поиск по имени файла Android studio Сбой приложения Android после использования фрагментов и ViewPager Начать фрагмент с помощью Intent внутри фрагмента Не удалось разрешить: скомпилировать 'com.google.firebase: firebase-config: 9.2.1' JavaCard 3 в реальном мире? Каков правильный, не устаревший способ пробудить устройство? Как избавиться от предупреждения: используйте '$' вместо '.' Для внутренних классов в Eclipse Параметры повторной настройки Android. Префикс «xmlns» не может быть привязан к любому пространству имен явно; Ни одно пространство имен для «xmlns» не должно быть привязано к любому префиксу явно

Android Studio – с Junit 4.12 "!!! Ожидается, что версия JUnit версии 3.8 или более поздней версии:

Пробовал предложения на этом посту, но я все равно получаю сообщение об ошибке:

!!! JUnit version 3.8 or later expected: java.lang.RuntimeException: Stub! at junit.runner.BaseTestRunner.<init>(BaseTestRunner.java:5) at junit.textui.TestRunner.<init>(TestRunner.java:54) at junit.textui.TestRunner.<init>(TestRunner.java:48) at junit.textui.TestRunner.<init>(TestRunner.java:41) Process finished with exit code -3 

Не уверен, что делать дальше. Попытка реорганизации порядка зависимости Junit. Не повезло, кто-нибудь еще получил эту проблему?

Android Studio V. 1.2.1.1

Solutions Collecting From Web of "Android Studio – с Junit 4.12 "!!! Ожидается, что версия JUnit версии 3.8 или более поздней версии:"

Решил проблему. Я запускал тесты JUnit в качестве стандартного «теста JUnit» в Android Studio . Я исправил проблему, сбросив конфигурацию в качестве Android Test на Android Test .

Я решаю эту проблему, перемещая «testCompile» junit: junit: 4.12 '"в первый порядок в блоке зависимости build.gradle

Запустив это, вы открываете старый проект в последнюю версию Android Studio 2.3 после автоматического обновления проекта.

Android Studio поддерживает тесты Android JUnit, которые должны запускаться с использованием текущего JRE хоста и надлежащим образом поддерживать JUnit 4+. Ошибка связана с неправильным использованием JRE.

С помощью Edit Configuration> выберите конфигурацию Android JUnit> отредактируйте JRE. Выберите любой вариант, используйте «Применить», а затем верните его в «Default (Android Platform)», чтобы он работал.

В моем случае я просто забыл, что я изменил вариант сборки на «release». Переключение на «отладка» исправлено. FML.