Android Studio: Не удалось найти: 'com.android.support:support-v4:19.1.0'

Я хочу создать приложение в Android Studio с помощью библиотеки поддержки, но при добавлении зависимости для библиотеки поддержки я получаю следующую ошибку:

Error:Failed to find: com.android.support:support-v4:19.1.0 

Вот мой файл build.gradle

 apply plugin: 'com.android.application' android { compileSdkVersion 19 buildToolsVersion '20' defaultConfig { applicationId "sample.myapplication" minSdkVersion 15 targetSdkVersion 19 versionCode 1 versionName "1.0" } buildTypes { release { runProguard false proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro' } } } dependencies { compile fileTree(dir: 'libs', include: ['*.jar']) compile 'com.android.support:support-v4:19.1.0' } 

Я загрузил библиотеку поддержки через менеджер sdk.

Solutions Collecting From Web of "Android Studio: Не удалось найти: 'com.android.support:support-v4:19.1.0'"

Хорошо, нашел проблему. Репозиторий поддержки Android отсутствовал. После установки и перезагрузки Android Studio он работал.

Если вы используете Android Studio, то в качестве дополнения к изменению файла build.gradle вручную вы также можете искать зависимость через зависимости библиотеки в разделе «Структура проекта».

Найдите, где com.android.support

Двойное нажатие этой зависимости будет генерировать эту строку в файле build.gradle:

 dependencies { compile 'com.android.support:support-v13:+' } 

А также, если вам интересно, о чем идет речь в этой библиотеке, это описано на страницах разработчиков на developer.android.com; Поддержка библиотеки .

Моя версия Android Studio – 1,1. Я выбираю tools -> Android -> SDK Manager , проверьте библиотеку поддержки Android и нажмите « Install packages , решив эту проблему.

В моем случае решение было так же просто, как запустить Build : Make Project . Никакое количество синхронизации градиента или очищающих кешей не сделало бы этого. Конечно, это требовало, чтобы мой проект был в состоянии, где он будет успешно строиться.

Мне помогла инструкция. По какой-то причине, когда мне пришлось переустановить последнюю версию андроид-студии, начальная загрузка библиотеки поддержки андроидов не удалась. Я просто повторил это. Последующие шаги, упомянутые и проверенные, были добавлены в файл build.gradle и сделали проект перестройки и хорошо прошли.

http://developer.android.com/tools/support-library/setup.html