Intereting Posts

Ошибка: для Android SDK требуется Android Developer Toolkit версии 22.6.1 или выше

Я установил adt версию 22.6.1 уже 2 дня назад. Он работал нормально. Внезапно, когда я открываю eclipse сегодня, он продолжает показывать мне следующую ошибку:

Для Android SDK требуется Android Developer Toolkit версии 22.6.1 или выше. Текущая версия – 22.2.1.v201309180102-833290. Обновите ADT до последней версии.

Вот скриншот моего Android SDK Manager eclipse: Введите описание изображения здесь

Я попытался выполнить следующие шаги для решения моей проблемы, как обсуждалось в этой ссылке

  1. Помощь | Установка нового программного обеспечения
  2. Выберите сайт обновления ADT (есть два, один с http:// и один с https:// . Если он не работает, попробуйте другой.
  3. Выберите раздел инструментов разработчика и нажмите кнопку Далее.
  4. Вы должны увидеть диалоговое окно, в котором говорится, что это программное обеспечение уже установлено, вместо этого будет выполнено обновление . При нажатии кнопки « ОК» будет установлено 22.6.1.

Но, к сожалению, это не сработало для меня.

Вот скриншот, который я прикрепляю, который показывает ошибку, которую я получаю при обновлении инструментов.

Введите описание изображения здесь

Как я могу избавиться от него?

Solutions Collecting From Web of "Ошибка: для Android SDK требуется Android Developer Toolkit версии 22.6.1 или выше"

Я решил этот вопрос вчера.

Выполните следующие действия: Справка -> Установка нового программного обеспечения -> Добавить -> ( NewUpdate любое имя NewUpdate ) -> добавьте этот URL: https://dl-ssl.google.com/eclipse/plugin/4.2 -> OK

Теперь он перечислит доступные обновления, которые в идеале должны быть adt 20.xx

Выберите элементы списка. Пусть он будет установлен. Eclipse перезагрузится и завершится.

Надеюсь, это поможет вам 🙂

Тем не менее, если кто-то сталкивается с этой проблемой, выполните следующие шаги:

  1. Скачать новый автономный SDK с сайта разработчика android

  2. Закройте eclipse, если он открыт, и скопируйте новый загруженный файл sdk в том же месте, где находится уже существующий старый sdk. Необходимо заменить файлы конфликтов и сохранить отдых.

  3. Не нужно удалять старый sdk. Копирование, как на шаге 2, обновит версию Android Developer Toolkit до 22.6.1 или выше, что требуется, и будет поддерживать уже загруженные API.

  4. Теперь запустите ваше затмение, и ошибка исчезнет навсегда. 🙂

Если у кого-то возникнут проблемы с этим, оставьте мне комментарий, попробуйте руководствоваться.

Мне удалось решить эту проблему, выполнив следующие действия:

  • Загрузите последнюю версию ADT (Win x64)
  • Удалена моя старая ADT-установка (она прослушивалась, когда я просто пытался перезаписать существующие файлы) – см. Эту проблему google
  • Скопировал zip-файл в C: \ (поскольку он жаловался на слишком длинные имена файлов при распаковке)
  • Распакован в папку установки ADT.
  • Обновления Ran и обновления менеджера SDK.

Теперь он работает, но я потерял свою симпатичную тему Eclipse. Ох, а цель adt не решается, проблема для другой темы.

Просто удалите существующий ADT и установите новую версию ADT. Обычно эти проблемы возникают, когда вы обновляете SDK, используя ссылку ниже.

 https://dl-ssl.google.com/android/eclipse/ 

ADT Bundle на developer.android.com кажется мне устаревшим.

Я исправил ту же проблему, загрузив eclipse ( Java EE был моим выбором, но вы можете выбрать свой вкус ) и Установка плагина Eclipse

Я использую OSX и сталкиваюсь с проблемой в течение 2 дней. Я решил проблему, выполнив следующие шаги:

-Download ADT Bundle от https://developer.android.com/sdk/index.html -Help -> Установить новое программное обеспечение -Write https://dl-ssl.google.com/android/eclipse/, а затем установить инструменты разработчика – Перезапустите eclipse и поднял ошибку ниже:

 Android SDK content Loader has encountered a problem.parseSdkContent failed java.lang.NullPointeException 

-Удалить папку .android в профиле пользователя. Перезапустить затмение

Ошибок и 22.6.1 не установлено.

Эти шаги решают мою проблему:

  1. Перейдите в раздел Справка -> Установить новое программное обеспечение .
  2. В нижнем поле нажмите « Что уже установлено»? текст.
  3. То вы увидите окно « Сведения об установке Eclipse» , пожалуйста, удалите все программное обеспечение конфликтов, в моем случае я удалю следующее программное обеспечение:

    • Android DDMS
    • Средства разработки Android
    • Android Hierarchy Viewer
    • Android Native Development
    • Android Traceview
    • Tracer для OpenGL ES
  4. После завершения удаления перезагрузите Eclipse.

  5. После открытия Eclipse, выполните следующие действия:

    • Перейдите в раздел Справка -> Установить новое программное обеспечение .
    • В разделе Работа с полем выберите или добавьте {ADT Plugin – https://dl-ssl.google.com/android/eclipse }.
    • Затем проверьте все доступные программы.
    • Нажмите « Далее»>, чтобы установить новейшее программное обеспечение.

Я надеюсь, это поможет вам 🙂

Для тех, кто пробовал все, но не получил никакого положительного результата. Я сделал следующее, и это сработало:

Удалите ADT, помогая из следующей ссылки: Удаление Android ADT

Теперь вы можете следить за установкой нового программного обеспечения, чтобы добавить ADT к вашему затмению. Таким образом, вы не столкнетесь с конфликтом, так как вы удалили старую версию.

В настоящее время у меня Eclipse и ADT установлены в том же каталоге, что и

 F:\eclipse \eclipse\ \sdk\ 

Я загрузил и установил последнюю версию ADT

 C:\Users\Rick\AppData\Local\Android\android-sdk 

Затем я скопировал содержимое папки C:\Users\Rick\AppData\Local\Android\android-sdk в папку F:\eclipse\sdk\ и позволю ему объединить все папки и перезаписать все.

Теперь у меня 22.6.1, и мне не нужно снова загружать все материалы платформы.

Сегодня я и один из моих друзей столкнулись с одной и той же проблемой, поэтому я пробовал много вещей, таких как перезапуск eclipse, проверка обновлений и т. Д., Но никто не работал на меня.

Затем я нашел решение отсюда, и он работает как шарм для меня, а также для моего друга.

Выполните следующие шаги:

  • Запустите Eclipse, затем выберите «Справка»> «Установить новое программное обеспечение».
  • Нажмите «Добавить» в верхнем правом углу.
  • В появившемся диалоговом окне «Добавить репозиторий» введите «ADT Plugin» для имени и следующего URL-адреса для местоположения:

https://dl-ssl.google.com/android/eclipse/

  • Нажмите «ОК».

Если у вас возникли проблемы с приобретением плагина, попробуйте использовать «http» в URL-адресе местоположения вместо «https» (https предпочтительнее из соображений безопасности).

  • В диалоговом окне «Доступное программное обеспечение» установите флажок «Инструменты разработчика» и нажмите «Далее».
  • В следующем окне вы увидите список инструментов для загрузки. Нажмите "Далее. Прочтите и примите лицензионные соглашения, затем нажмите «Готово».
  • Если вы получите предупреждение о безопасности, указывающее, что подлинность или действительность программного обеспечения не может быть установлена, нажмите «ОК».
  • По завершении установки перезапустите Eclipse.

«Установить новое программное обеспечение» под управлением Eclipse НЕ будет работать, потому что оно конфликтует с версией № 22. Я только что загрузил новый пакет Eclipse: Получите Android SDK – сайт google , извлеките его в новой папке, и это сделано.

Он работает бесперебойно, без проблем.

Несколько советов, которые помогут вам сэкономить время:

  1. Резервное копирование рабочего пространства (на всякий случай) – лично это не использовалось.
  2. После того как вы откроете новый eclipse.exe, он попросит вас выбрать рабочее пространство – просто брови в рабочее пространство ols, и он импортирует все ваши проекты (без проблем).
  3. Чтобы снова сэкономить время загрузки и установки SDK, я вырезаю и вставляю библиотеку OLD SDK из предыдущего каталога пакетов в новый ( сначала закройте свой новый Eclipse) .
  4. При повторном открытии Eclipse вы можете получить сообщение об ошибке, в котором говорится, что Eclipse не может найти каталог SDK. Он попросит вас открыть «Настройки». После открытия перейдите в новый каталог SDK (тот, который вы только что скопировали). Это позволит сэкономить вам время на повторную установку всех обновлений SDK, которые вы сделали в предыдущем Eclipse.

Получайте удовольствие, это действительно неважно.