Для Android SDK требуется Android Developer Toolkit версии 14.0.0 или выше. … Пожалуйста, обновите ADT до последней версии

Пожалуйста, помогите мне с исправлением следующей ошибки:

This Android SDK requires Android Developer Toolkit version 14.0.0 or above. Current version is 12.0.0.v201106281929-138431. Please update ADT to the latest version. 

Я столкнулся с этой проблемой при использовании Eclipse.

Solutions Collecting From Web of "Для Android SDK требуется Android Developer Toolkit версии 14.0.0 или выше. … Пожалуйста, обновите ADT до последней версии"

Причина в том, что вы обновили sroid sroid, но ваш Android-модуль adt не обновлен. Поэтому обновление вашего плагина Eclipse решит проблему.

Эта ошибка возникает из-за несовместимости между ADT и SDK.

Исправить это:

  1. Eclipse> Справка
  2. Установка нового программного обеспечения
  3. Добавьте это в раздел «Работа с» и нажмите «Ввод».
  4. После того, как в списке появятся инструменты разработчика, проверьте его и нажмите «Далее».
  5. Перезапуск eclipse после завершения загрузки

Аналогичная проблема уже обсуждалась здесь: Eclipse: не позволит мне использовать Android SDK, ошибочно утверждает, что мой ADT устарел

  1. В Eclipse перейдите в Help.
  2. Выберите пункт «Установить новое программное обеспечение».
  3. В этом диалоговом окне нажмите кнопку «Добавить …». Это вызовет новый, более маленький диалог.
  4. Введите имя «ADT» и местоположение: « https://dl-ssl.google.com/android/eclipse/ »
  5. После загрузки вы получите инструменты для разработчиков и плагины NDK
  6. Проверьте оба варианта, если хотите, или установите Инструменты разработчика.
  7. Нажмите "Далее
  8. Принять лицензии и Закончить

Если вы не хотите обновлять свою версию ADT, вы можете сделать это, чтобы исправить свою проблему.

Измените $ {android-sdk} /tools/lib/plugin.prop plugin.version на текущую версию, перезапустите eclipse.

 # begin plugin.prop plugin.version=22.3.0 # end plugin.prop 

наслаждайся этим.

Для тех из вас, кто испытывает эту проблему:

Eclipse говорит, что ADT нуждается в обновлении. Вы щелкните, чтобы проверить наличие обновлений. Он сообщает, что обновлений нет.

Вам нужно запустить Eclipse в качестве администратора. Это немедленно устранит проблему.

Eclipse -> Справка -> Проверить наличие обновлений

Проверьте «Инструменты разработки Android» и установите обновление

Как правило, версия плагинов ADT в Eclipse сопряжена с определенной версией SDK. Это не очень хорошо документировано, но если вы обновите его в любой момент, вам нужно обновить другое. Номер версии инструментов и плагинов обычно синхронизирован, но в некоторых случаях это не так. Фактически, сейчас (27 июня) SDK – это версия 19, а плагины – 18. Конечно, это произойдет позже, когда Google IO начнет. Цель состоит в том, чтобы синхронизировать номера версий, но это не всегда так.

Вы можете получить более старые версии ADT и / или SDK с сайта инструментов Android. В некоторых случаях вам нужно выяснить секрет, чтобы URL-адрес напрямую загружал старые пакеты, но они есть.

Однако это не обязательно. Плагины и SDK работают со всеми предыдущими версиями платформы, поэтому вы всегда должны быть уверены в установке последних SDK и плагинов прямо с сайта разработчиков Android.