Intereting Posts
Самый эффективный способ показать анимацию по кадру за кадром Проблемы с Android 4.0 и 4.1 Bluetooth. Обнаружение сломанной связи и падающего спаривания Фон стиля AppCompat, распространяемый на изображение в ToolBar Как отладить apk, подписанный для выпуска? Недопустимый вектор тегов GROUP BY с помощью CursorLoader Как установить тему в ProgressDialog? Android – Можно ли использовать навигационный ящик с правой стороны? Программно сделать цвет более прозрачным Укажите конфигурацию подписи для Gradle и Cordova 5 Индивидуальный просмотр камеры и вращение в Zxing для QR-кода? Активность мастера полноэкранного действия. Как отключить отображение панели действий при взаимодействии с устройством? Может ли ListView содержать фрагменты Java.lang.ClassNotFoundException в моем приложении для Android, но я понятия не имею, почему Используйте постоянное уведомление, чтобы позволить пользователю вернуться к запущенному приложению Android.

Android: Import DrawerLayout не может быть разрешен

Я пытаюсь импортировать классы, необходимые для использования нового «навигационного ящика» с Android http://developer.android.com/design/patterns/navigation-drawer.html#ImpactOnNav

DrawerLayout: http://developer.android.com/reference/android/support/v4/widget/DrawerLayout.html

ActionBarDrawerToggle: http://developer.android.com/reference/android/support/v4/app/ActionBarDrawerToggle.html

Импорт android.support.v4.widget.DrawerLayout не может быть разрешен Импорт android.support.v4.app.ActionBarDrawerToggle не может быть разрешен

Я обновил библиотеки до последней версии, но эти классы не распознаются.

Solutions Collecting From Web of "Android: Import DrawerLayout не может быть разрешен"

Как обновить JAR в библиотеках?

Обычно я делаю это, копируя файл. Вы найдете JAR внутри $ANDROID_SDK/extras/android/support , где $ANDROID_SDK находится там, где установлен Android SDK.

Если вы используете Eclipse, если вы скопируете это на уровне файловой системы и откроете Eclipse, нажмите <F5> если проект выделен в диспетчере пакетов, поэтому Eclipse подберет изменения. Легче вытащить его из SDK и отбросить JAR в libs/ right в Eclipse, который будет обновлять файловую систему и позволить Eclipse узнать об этом изменении.

Возможно, что опция Eclipse для добавления JAR (щелкните правой кнопкой мыши по проекту, затем выберите «Инструменты Android»> «Добавить библиотеку поддержки … из контекстного меню»), также это сделает. Этот конкретный подход не работает для меня из-за некоторых особенностей моей среды разработки.

Скопируйте банку поддержки из Android SDK в папку libs. Должно быть в <ANDROID SDK FOLDER>\extras\android\compatibility\v13 .

В студии Android я обнаружил, что добавление зависимостей решило проблему.

В меню файла найдите структуру проекта. В разделе «приложение» найдите вкладку зависимостей. Нажмите на зеленый плюс справа. Выберите зависимость библиотеки.

Я добавил поддержку – v4 и support-v13.