Синхронизация проекта Android Gradle завершилась неудачно из-за целевой версии

Поскольку в SDK Manager появился новый API Android 6.0, в файле уровня приложения появился файл build.gradle для обновления

ИЗ

androidTestCompile 'com.android.support:support-annotations:22.0.1' compile 'com.android.support:appcompat-v7:22.0.1' 

К

 androidTestCompile 'com.android.support:support-annotations:23.0.0' compile 'com.android.support:appcompat-v7:23.0.0' 

Я еще не загрузил новое обновление из диспетчера sdk для Android 6 (API 23), но все же изменил следующие данные, как показано ниже,

ДО

 compileSdkVersion 22 buildToolsVersion "22.0.1" targetSdkVersion 22 androidTestCompile 'com.android.support:support-annotations:22.0.1' compile 'com.android.support:appcompat-v7:22.0.1' 

ПОСЛЕ

  compileSdkVersion 23 buildToolsVersion "23.0.0" targetSdkVersion 23 androidTestCompile 'com.android.support:support-annotations:23.0.0' compile 'com.android.support:appcompat-v7:23.0.0' 

Поскольку я еще не загрузил новый API 6.0, произошла следующая ошибка

 Error:Cause: failed to find target with hash string 'android-23' in: C:\Users\DRONE\AppData\Local\Android\sdk 

Итак, теперь я снова изменил настройку в файле build.gradle на уровне приложения, как и раньше, но ошибка не устранена. Произошла одна и та же ошибка.

Как я могу решить это сейчас?

Solutions Collecting From Web of "Синхронизация проекта Android Gradle завершилась неудачно из-за целевой версии"

Обычно это вызвано отсутствием API 23. После обновления SDK до более новой версии он часто перезаписывает build.gradle до самой высокой версии SDK версии API, даже если вы ее не загрузили. Самый простой способ – загрузить API 23.

Я думаю, это может быть вызвано тем, что у вас нет 23 API, откройте «Инструменты»> «Android»> «Менеджер SDK» и проверьте, установлен ли API-23.

Попробуйте добавить «+», например: compile 'com.android.support:appcompat-v7:23.+'

Вы также должны обновить свои Android Studio API (как сказал Кун).

Да, как говорили другие, вам нужно установить API-23 через SDK Manager, но это длинный список загрузок, и если вы не хотите сразу их устанавливать, вы можете просто установить один из них под названием «SDK Platform» в API-23