Intereting Posts
Импортировать проект eclipse в студию Android – ошибка «этот проект относится к рабочему пространству Eclipse …» Проводник Android Device Monitor не работает с Android 7 (API 24+) Файл сборки Android Gradle с функцией Time Stamp работает вчера Создание пользовательских больших уведомлений Как отображать таймер обратного отсчета в строке состояния в android, например, отображение времени? Как извлечь атрибут name из массива строк? Как изменить размер веб-представления android после добавления в него данных Как установить край для вертикальной полосы прокрутки с правого края в ListView? В чем основное различие между фрагментом и активностью? Какой код можно записать в фрагменте? Может android PopupWindow показать другое PopupWindow? Почему FrameLayout используется для фрагментов? Повторное использование макета XML и кода Основной поток, блокирующий поток веб-приложений Android Android studio 0.5.9: 2 раздражающие предупреждения о недоставке Android-фрагменты против составных элементов управления

Android Dex: невозможно выполнить DX (IntelliJ)

Я следую шагам от https://stackoverflow.com/a/5271194/1973953 этой ссылки.

Но когда я запускаю приложение, я получаю эти ошибки

Введите описание изображения здесь

У меня есть только одна строка в файле project.properties " target = android-11 "

И это мой AndroidManifest.xml

Введите описание изображения здесь

Поэтому мой вопрос в том, почему я получаю эти ошибки и как их решать …

Solutions Collecting From Web of "Android Dex: невозможно выполнить DX (IntelliJ)"

Когда у меня возникла эта проблема, это было потому, что библиотека ActionBarSherlock, добавленная в мой проект, определяла android-support-v4.jar как зависимость от компиляции, и эта банка уже была включена в мой проект, поэтому во время компиляции было несколько копий / версий DEX ,

Решение заключалось в том, чтобы изменить зависимость модуля ActionBarSherlock для этой банки как Runtime вместо компиляции, поскольку мой проект уже предоставлял ее.

Я просто изменил версию Android SDK в настройках проекта ( Intellij ), и ошибка была решена. Я использовал API-14 но, по словам менеджера SDK, в моей системе был установлен только API-19 . Поэтому я рекомендую взглянуть на менеджера SDK и посмотреть, какие версии API у вас есть, и выбрать правильную версию API / android.

Вы не можете создавать с использованием API, который не установлен на вашем компьютере.

Перейдите в настройки вашего проекта / модуля и выберите версию API, которую вы фактически установили. Или установите версию API в SDK. (Я бы просто прокомментировал нисходящий ответ @ hkazemi, чтобы спросить, почему он был ниспровергнут, потому что это было исправление для меня, но я так плохо знаю, я добавляю ответ.)

Проверьте, добавлен ли один и тот же JAR-файл более одного раза.
Если да, удалите любую из них из папки libs и очистите свой проект.

В идее intellij: перейти к структуре проекта и удалить одну из повторяющихся библиотек .jar [работал для меня]