ADT 22.2 Мастер создания новых приложений: неподдерживаемая зависимость шаблона: обновите плагин Android Eclipse

Я нашел ответы на этот вопрос, но никто не работал для меня. При получении последнего экрана при создании нового проекта я получаю следующее сообщение:

Неподдерживаемая зависимость шаблона: обновите плагин Android Eclipse

Необходимая версия пуста (в некоторых случаях она отображается как 8). Установленная версия – 18.

Я уже пробовал многие из решений, которые я нашел здесь, например:

  • Запуск менеджера SDK в качестве администратора
  • Запустить Eclipse в качестве администратора
  • Переустановите компоненты поддержки из дополнительной папки SDK и перезапустите Eclipse,

Ни один из них не работал для меня.

Есть ли другое решение?

Solutions Collecting From Web of "ADT 22.2 Мастер создания новых приложений: неподдерживаемая зависимость шаблона: обновите плагин Android Eclipse"

Обновление 2: теперь (2013-09-19T17: 00: 00Z) доступны обновления ADT 22.2.1 и Tools 22.2.1, которые исправляют эту проблему:

  • Используйте Eclipse> Справка> Проверить наличие обновлений, чтобы получить ADT 22.2.1
  • Используйте SDK Manager для получения инструментов 22.2.1

Вам нужны обе части, чтобы исправить проблему. Также были обновлены пакет ADT и пакет установщика на http://developer.android.com/sdk/index.html .

( Отсюда )


Обновление : отчет об ошибке теперь имеет ответ с прикрепленными файлами с фиксированным шаблоном и следующие комментарии:

Это мое плохое. Я был в середине изменения системы зависимостей, используемой шаблонами, и переходное состояние, полученное в этой сборке инструментов. Шаблоны установлены в основной ветке AOSP.

Я приложил снимок текущих шаблонов действий. Замена папки sdk / tools / templates / activities с содержимым этого zip должна решить эту проблему.

Я прошу прощения за доставленные неудобства.

Мое более раннее обходное решение ниже.


Обходной путь к ошибке :

Для пустых действий :

  1. Изменить <sdk>/tools/templates/activities/BlankActivity/template.xml

  2. Прокомментируйте зависимость:

     <!--<dependency name="appcompat" version="v7" />--> 

Для Master / Detail Flow :

  1. Изменить <sdk>/tools/templates/activities/MasterDetailFlow/template.xml

  2. Прокомментируйте зависимости:

     <!--<dependency name="support" version="v4" /> <dependency name="android-support-v4" revision="8" />--> 

В заключение:

  • Перезапустить Eclipse

При необходимости скопируйте android-support-v4.jar из <sdk>/extras/support/v4 в свои libs .

@ Šantić A. Miroslav – Я не уверен, почему, но удаление инструментов SDK не понижается до предыдущей версии. Папка <sdk>/tools просто исчезла и произошла ошибка пути .


Я попытался загрузить с http://dl-ssl.google.com/android/repository/tools_r22-windows.zip , разархивировать его и заменить его на папку <sdk>/tools чтобы понизить инструменты SDK, и это сработало для меня.

У меня такая же проблема. Это происходит, когда я обновил Android SDK Tools до версии 22.2. Переход на более раннюю версию избавит вас от этой проблемы.

Я столкнулся с той же проблемой последние пару часов, и я решил это … Я загрузил SDK (для своего Mac) по приведенной ниже ссылке.

[Для Mac] http://dl-ssl.google.com/android/repository/tools_r22-macosx.zip

[Для Windows] http://dl-ssl.google.com/android/repository/tools_r22-windows.zip

[Для Linux] http://dl-ssl.google.com/android/repository/tools_r22-linux.zip

Я пошел в Android установленный каталог -> инструмент и заменил все содержимое загруженными файлами.

Я перезапустил Eclipse, выполнил новый проект , и он работает нормально!

Попробуйте мой обходной путь:

  1. Создать новый проект с помощью командной строки
    • Примечания: НЕ создавайте его в рабочей области Eclipse, создайте его в другом месте, например ~/tmp/
    • Например, android create project --target 1 --name MyAndroidApp --path ./MyAndroidAppProject --activity MyAndroidAppActivity --package com.example.myandroid
  2. Затем в Eclipse « Импортировать » проект, который вы только что создали

Рабочее решение

Я загрузил adt-bundle-windows-x86_64-20130729 с http://burnbit.com/torrent/251451/adt_bundle_windows_x86_64_20130729_zip . После обновления я также получил ту же ошибку, что и вы. Без обновления я создал проект, так что теперь он работает. Так сделайте этот шаг. Эта ошибка возникает из-за несоответствия версии. Так сделайте этот шаг.

Надеюсь, это решит вашу проблему.

В последней версии SDK есть ошибка. Пожалуйста, понизитесь до r_22. Меня устраивает.

Вам нужно обновить плагин ADT для него. Последняя версия инструмента Android SDK – 22.2.1, и для этого вам понадобится пакет ADT 22.2.1. Ссылка для загрузки: http://www.softpedia.com/get/Programming/Components-Libraries/Android-Development-Tools.shtml