Внедрение вкладок ActionBar с API-интерфейсов v4

В настоящее время мое приложение использует пакет совместимости Fragments / v4 для поддержки версий Android вплоть до 1,6. Это означает, что все мои фрагменты наследуются от версии Fragment пакета совместимости. В настоящее время я пытаюсь переделать части приложения, чтобы воспользоваться функциями Honeycomb, такими как ActionBar .

Я уже использую свою собственную action-bar-подобную реализацию на устройствах pre-3.0, а в противном случае – в панели действий Honeycomb. Этот бит не является проблемой.

Проблема, с которой я сталкиваюсь, заключается в попытке реализовать вкладки с помощью ActionBar. ActionBar.TabListener ожидает, что родные классы Fragment и FragmentTransaction будут работать – поэтому попытка использовать классы Fragment (которые наследуются от библиотеки совместимости) не компилируется.

Итак, есть ли у кого-нибудь идеи, как я могу использовать фрагменты, которые используют версию пакета совместимости Fragment с вкладками ActionBar ?

Tldr: как я могу использовать вкладки ActionBar с фрагментами, которые наследуются от библиотеки совместимости v4?

Solutions Collecting From Web of "Внедрение вкладок ActionBar с API-интерфейсов v4"