Intereting Posts
«Дублируйте файл lib, скопированный в APK-META-INF / license.txt» в Android Studio Жизненный цикл активности Android после нажатия кнопки «Назад» Представления внутри пользовательской ViewGroup не отображаются после изменения размера Ароматы Gradle для Android с настраиваемыми наборами источников – какими должны быть файлы градиента? Android: AppWidget с настраиваемым представлением не работает Unmarshalling XML-файлы в Java-объекты в Android? Eclipse говорит мне, что у моего проекта есть ошибки, ничего не выделено красным цветом Как вызвать getFragmentManager на Recycler.Adapter? Создание UML-диаграммы в Android Studio Android In-App Billing v3: не получает подписей Только исходный поток, создавший иерархию представлений, может коснуться его представлений. На андроиде Откройте изображение, используя URI в средстве просмотра изображений галереи по умолчанию в Android Android: как получить строку в определенной локали БЕЗ изменения текущей локали Вычислить подшипник компаса / заголовок для местоположения в Android Библиотека "libmaliinstr.so" не найдена

Невозможно установить плагины Кордовы из Git на CLI

Я уже давно ломаю голову над этим. Я разрабатываю приложение для Android в Windows 7 в Cordova 3.4 и я не могу установить какие-либо из неосновных плагинов для установки (например, Google Analytics , Social Share ). Я знаю, что у меня есть плагин, узел, git, cordova и CLI, потому что, когда я ввожу их в командную строку, я возвращаю действительный ответ. Android SDK работает, и я обновил все эти модули и попытался переустановить. Вот ошибка, которую я получаю, когда пытаюсь установить плагин, который не является частью ядра Cordova:

 C:\Users\UserName\Desktop\hello>cordova plugin add https://github.com/danwilson/google-analytics-plugin.git Fetching plugin "https://github.com/danwilson/google-analytics-plugin.git" via git clone Error: Command failed: fatal: could not create work tree dir 'C:\Users\DAVIDH~1\AppData\Local\Temp\plugman\git\1397683376354'.: No such file or directory 

Мне интересно, это проблема PATH или нет, хотя я пробовал много решений, связанных с этим. Ваши советы и рекомендации приветствуются. Благодаря!

Solutions Collecting From Web of "Невозможно установить плагины Кордовы из Git на CLI"

Кажется, есть ошибка в зависимостях источника git от Windows.

Попробуйте создать каталог вручную:

 mkdir C:\Users\DAVIDH~1\AppData\Local\Temp\plugman\git 

Затем :

 git clone https://github.com/danwilson/google-analytics-plugin.git 

Оттуда: https://github.com/sbt/sbt/issues/895

РЕДАКТИРОВАТЬ

Я удалил числовое расширение, которое не нужно, чтобы следовать замечанию FugueWeb

ОБНОВЛЕНИЕ (С сентября 2014 года)

Как отмечено в ответе Дарена Била, а также в проблеме, связанной выше, эта ошибка исправлена ​​в Git 1.9.4. Загрузка последней версии GIT для Windows должна обойти эту проблему.

У меня была эта точная проблема на моем рабочем столе, но не на моем ноутбуке, как было предложено выше, это похоже на проблему Git. Установка последней версии Git на моем рабочем столе (1.9.4) устранила проблему.

Я столкнулся с подобной проблемой при выдаче команд из cygwin, структура временных файлов cygwin немного отличается

В ручном создании родительских папок (plugman и git), которых не существует, исправлена ​​проблема (впоследствии можно создать пронумерованные папки в папках plugman / git)