Конфликтная зависимость при попытке установить плагин ADT в eclipse

Вот мои спецификации: Eclipse: 3.5.2 Плагин ADT: 11.0.0 ПК: Windows 7

До сих пор я установил Android SDK и Eclipse. Однако, когда я пытаюсь установить плагин ADT в eclipse, я получаю следующую ошибку:

Cannot complete the install because of a conflicting dependency. Software being installed: Android Development Tools 

11.0.0.v201105251008-128486 (com.android.ide.eclipse.adt.feature.group 11.0.0.v201105251008-128486) Программное обеспечение, установленное в настоящий момент: Eclipse SDK 3.5.2.M20100211-1343 (org.eclipse.sdk.ide 3.5.2.M20100211-1343) Только одно из следующих может быть установлено сразу: Core Runtime 3.6.0.v20100505 (org.eclipse.core.runtime 3.6.0.v20100505) Core Runtime 3.5.0.v20090525 (орг. Eclipse.core.runtime 3.5.0.v20090525) Не может удовлетворить зависимость: От: Android Development Tools 11.0.0.v201105251008-128486 (com.android.ide.eclipse.adt.feature.group 11.0.0.v201105251008-128486) To : Org.eclipse.wst.sse.core 0.0.0 Не может удовлетворить зависимость: От: EMF Common 2.6.0.v20100614-1136 (org.eclipse.emf.common 2.6.0.v20100614-1136) To: bundle org.eclipse .core.runtime [3.6.0.4.0.0) Не может удовлетворить зависимость: От: EMF Common 2.6.0.v20100914-1218 (org.eclipse.emf.common 2.6.0.v20100914-1218) To: bundle org.eclipse .core.runtime [3.6.0.4.0.0) Не может удовлетворить зависимость: От: Eclipse Platform 3.5.2.R35x_v20100210-0800-9hEiFz mFst-TiEn9hNYgDWg1XN8ulH_JvCNGB (org.eclipse.platform.feature.group 3.5.2.R35x_v20100210-0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB) To: org.eclipse.rcp.feature.group [3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6] Невозможно удовлетворить зависимость: От : Eclipse RCP 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6 (org.eclipse.rcp.feature.group 3.5.2.R35x_v20100119-9SA0FxwFnoCU5XxWItFdXXb27BA6) Кому: org.eclipse.core.runtime [3.5.0.v20090525] Не может удовлетворять зависимость: От: Проект Eclipse SDK 3.5.2.R35x_v20100119-7Q7bARBPWUHM_CSjz-8bF1f7_n8rLSyWHoiKoyxBQSGT4 (org.eclipse.sdk.feature.group 3.5.2.R35x_v20100119-7Q7bARBPWUHM_CSjz-8bF1f7_n8rLSyWHoiKoyxBQSGT4) To: org.eclipse.platform.feature.group [3.5.2.R35x_v20100210- 0800-9hEiFzmFst-TiEn9hNYgDWg1XN8ulH_JvCNGB] Невозможно удовлетворить зависимость: От: Eclipse SDK 3.5.2.M20100211-1343 (org.eclipse.sdk.ide 3.5.2.M20100211-1343) Кому: org.eclipse.sdk.feature.group [3.5 .2.R35x_v20100119-7Q7bARBPWUHM_CSjz-8bF1f7_n8rLSyWHoiKoyxBQSGT4] Не может удовлетворить зависимость Ency: From: Structured Source Model 1.1.500.v201006020308 (org.eclipse.wst.sse.core 1.1.500.v201006020308) To: bundle org.eclipse.emf.common [2.4.0.3.0.0) Не может удовлетворить зависимость : From: Structured Source Model 1.1.502.v201008311901 (org.eclipse.wst.sse.core 1.1.502.v201008311901) To: bundle org.eclipse.emf.common [2.4.0.3.0.0) Не может удовлетворить зависимость: From: Structured Source Model 1.1.504.v201102160550 (org.eclipse.wst.sse.core 1.1.504.v201102160550) To: bundle org.eclipse.emf.common [2.4.0.3.0.0)

Какие-либо предложения? Я видел несколько сообщений о повторной установке eclipse, но это то, что мне не нравится делать, потому что было очень больно найти 64-битную версию в первую очередь.

Если вы хотите предложить повторно установить eclipse, я был бы очень признателен, если бы вы нашли ссылку для загрузки для 64-битной версии Windows. спасибо 🙂

Или если вы знаете, как исправить эту ошибку напрямую, что было бы очень полезно: D

Solutions Collecting From Web of "Конфликтная зависимость при попытке установить плагин ADT в eclipse"

Похоже, что для последней версии ADT требуется Eclipse Helios (3.6). Это кажется странным, поскольку я не могу найти, где это требование документировано.

Вы можете попробовать получить новую версию Eclipse . Вы также можете воспользоваться более ранней версией ADT, хотя мне трудно найти ее.

Если вы обновляетесь с версии 3.6, и вы отключили новое затмение в старом исходном местоположении, вы получите ошибку зависимости от конфликтования – только один из них может быть установлен одновременно и т. Д. Tc. В этом случае полностью удалите свою старую папку eclipse. Разархивируйте новый, и он будет работать! Не нужно добавлять какие-либо репозитории!

Я думаю, вы можете удалить SDK для Android. Затем сначала добавьте или установите плагин adt в eclipse. То при перезапуске eclipse он автоматически начнет задавать вам путь к Android SDK. Если не спрашивать, просто перейдите в Window-> prefrences-> Android и установите путь к sdk android (распакованная папка android) (путь к инструменту dir).

Вероятно, это немного лат для этого, но я запускал Eclipse Helios 3.6 и получил одинаковые сообщения о конфликтах зависимости. Я пошел в меню справки и сделал проверку обновлений, и он обновил eclipse sdk. Я перезагрузился и снова попытался установить плагин ADT, и он сработал.

Eclipse устанавливает по умолчанию рабочую область с названием workspace. Это вызывает проблемы при попытке обновления и т. Д., Поскольку метаданные в рабочей области остаются в предыдущей заставке.

Сначала сделайте копию рабочего пространства, чем удалите его, и попробуйте установить 3.7 и снова заново, и все должно работать.

BTW, отныне … назовите рабочее пространство eclipse по номеру версии eclipse, чтобы избежать проблемы.