Intereting Posts

Получение ошибки «Требуется версия Gradle 1.10. Текущая версия 1.12. "При выполнении" обертки градации "?

Я пытаюсь выполнить gradle wrapper для Android-проекта, и эта ошибка возникает:

Возникла проблема с оценкой корневого проекта «myapp».

> Требуется Gradle версия 1.10. Текущая версия – 1.12. Если вы используете оболочку градиента, попробуйте отредактировать дистрибутивUrl в /Users/dude/myapp/gradle/wrapper/gradle-wrapper.properties до gradle-1.10-all.zip

Моя задача wrapper в build.gradle выглядит так:

 task wrapper(type: Wrapper) { gradleVersion = "1.12" } 

Недавно я обновился до Gradle v1.12 через Homebrew. Разве это не поддерживается или что-то еще? Если да, то где я могу это проверить?

Solutions Collecting From Web of "Получение ошибки «Требуется версия Gradle 1.10. Текущая версия 1.12. "При выполнении" обертки градации "?"

Для конкретной версии плагина Gradle Android требуется определенная версия Gradle (по крайней мере на данный момент), и, похоже, для вашей версии плагина Gradle Android требуется Gradle 1.10. Вы можете найти дополнительную информацию об этом в документации для плагина Gradle Android.

PS: Задача обертки выше создает файлы, необходимые для запуска Gradle с помощью (сгенерированного) скрипта gradlew , который является предпочтительным способом запуска Gradle (без ручной установки, каждая сборка может указывать в своем gradle-wrapper.properties который требуется для версии Gradle) ).

Версия плагина Android-плагинов должна быть совместима с версией Gradle. Ознакомьтесь с таблицей сопоставления совместимости версий здесь: http://tools.android.com/tech-docs/new-build-system/version-compatibility

Введите описание изображения здесь

У меня такая же проблема. Оказалось, что старая Android-студия создала файлы, связанные с градиентом, на один уровень выше моей папки приложений. В моем случае путь был в ~ / git /, и мой проект был в ~ / git / myproject. Я использовал Android Studio RC2 сейчас, и независимо от того, как я изменил конфигурацию внутри проекта, gradle все еще хотел использовать старую версию 1.10. Поэтому я повторно проверил проект по новому пути и обновил ссылку на версию gradle в проекте, а затем скомпилировал.