Сбой сборки при запуске-андроиде из-за зависимостей

Проблема при запуске run-android. Я столкнулся с проблемой, я думаю, это чувак с зависимостями градиентов.

Я даже попробовал sudo, что дает некоторую другую случайную ошибку, говорящую $ ANDROID_HOME. Это не проблема.

JS server already running. Building and installing the app on the device (cd android && ./gradlew installDebug)... FAILURE: Build failed with an exception. * What went wrong: A problem occurred configuring project ':app'. > Could not resolve all dependencies for configuration ':app:_debugCompile'. > Could not find com.android.support:appcompat-v7:23.0.0. Searched in the following locations: file:/Users/iraycd/.m2/repository/com/android/support/appcompat-v7/23.0.0/appcompat-v7-23.0.0.pom file:/Users/iraycd/.m2/repository/com/android/support/appcompat-v7/23.0.0/appcompat-v7-23.0.0.jar https://jcenter.bintray.com/com/android/support/appcompat-v7/23.0.0/appcompat-v7-23.0.0.pom https://jcenter.bintray.com/com/android/support/appcompat-v7/23.0.0/appcompat-v7-23.0.0.jar Required by: AwesomeProject:app:unspecified > Could not find com.android.support:appcompat-v7:23.0.0. Searched in the following locations: file:/Users/iraycd/.m2/repository/com/android/support/appcompat-v7/23.0.0/appcompat-v7-23.0.0.pom file:/Users/iraycd/.m2/repository/com/android/support/appcompat-v7/23.0.0/appcompat-v7-23.0.0.jar https://jcenter.bintray.com/com/android/support/appcompat-v7/23.0.0/appcompat-v7-23.0.0.pom https://jcenter.bintray.com/com/android/support/appcompat-v7/23.0.0/appcompat-v7-23.0.0.jar Required by: AwesomeProject:app:unspecified > com.facebook.react:react-native:0.11.0 > Could not find com.android.support:support-v4:21.0.3. Searched in the following locations: file:/Users/iraycd/.m2/repository/com/android/support/support-v4/21.0.3/support-v4-21.0.3.pom file:/Users/iraycd/.m2/repository/com/android/support/support-v4/21.0.3/support-v4-21.0.3.jar https://jcenter.bintray.com/com/android/support/support-v4/21.0.3/support-v4-21.0.3.pom https://jcenter.bintray.com/com/android/support/support-v4/21.0.3/support-v4-21.0.3.jar Required by: AwesomeProject:app:unspecified > com.facebook.react:react-native:0.11.0 > com.facebook.fresco:fresco:0.6.1 > com.facebook.fresco:drawee:0.6.1 AwesomeProject:app:unspecified > com.facebook.react:react-native:0.11.0 > com.facebook.fresco:fresco:0.6.1 > com.facebook.fresco:imagepipeline:0.6.1 * Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. BUILD FAILED Total time: 11.247 secs Could not install the app on the device, see the error above. 

Где я неправ?

Solutions Collecting From Web of "Сбой сборки при запуске-андроиде из-за зависимостей"

Не удалось установить репозиторий поддержки Android, снова выполнил все шаги здесь: https://facebook.github.io/react-native/docs/android-setup.html

https://github.com/facebook/react-native/issues/2772#issuecomment-140843907

Не похоже, что вы обновили свои библиотеки на своем компьютере до последней версии. Загрузите новые версии библиотеки поддержки / appcompat, а затем повторите попытку.

Похоже, что у вас нет установленного android sdk и / или путь к нему не настроен должным образом. Подробные инструкции о том, как это сделать в документации по настройке android, можно найти в инструкции по установке и настройке SDK .

В случае, как и я, ничто другое, что вы прочитали, не сработало, это сработало для меня:

  1. Проверьте последний снимок изменений в исходном элементе управления
  2. Удалить каталог проекта из вашей системы
  3. Проверьте свой код от источника управления
  4. npm cache clean && npm install
  5. watchman watch-del-all
  6. react-native start -- --reset-cache
  7. react-native run-android

: Ум-выдувное:

Для тех, кто сталкивается с этой проблемой, когда они пытаются просто использовать Android SDK Manager ( tools/android ), мне пришлось запустить менеджер SDK как root (например, sudo ./tools/android ), чтобы обойти эту ошибку.

К сожалению, запуск X11-переадресованной программы с правами root иногда может привести к возникновению собственных проблем. Если у вас возникли проблемы с попыткой запустить менеджер SDK с правами root, см. Здесь этот ответ . В частности, я смог запустить диспетчер SDK в качестве обычного пользователя, но попытка запустить его как root всегда терпела неудачу.